2010/8/25 Rich Megginson <rmeggins@redhat.com>
Andrey Ivanov wrote:
I wanted to configure the replication over SSL (both with SSL
mechanism which was available in previous versions) and by TLS using
simple bind (both in multimaster or single master-dedicated consumer models).

I've tried to configure it with command line and with the console. The
configuration and the initial initialisation are ok :

[25/Aug/2010:18:30:44 +0200] NSMMReplicationPlugin - replica_config_delete: Warning: The changelog for replica dc=id,dc=polytechnique,dc=edu is no longer valid since the replica config is being deleted.  Removing the changelog.
[25/Aug/2010:18:34:33 +0200] NSMMReplicationPlugin - multimaster_be_state_change: replica dc=id,dc=polytechnique,dc=edu is going offline; disabling replication
[25/Aug/2010:18:34:33 +0200] - WARNING: Import is running with nsslapd-db-private-import-mem on; No other process is allowed to access the database
[25/Aug/2010:18:34:39 +0200] - import userRoot: Workers finished; cleaning up...
[25/Aug/2010:18:34:40 +0200] - import userRoot: Workers cleaned up.
[25/Aug/2010:18:34:40 +0200] - import userRoot: Indexing complete.  Post-processing...
[25/Aug/2010:18:34:40 +0200] - import userRoot: Flushing caches...
[25/Aug/2010:18:34:40 +0200] - import userRoot: Closing files...
[25/Aug/2010:18:34:40 +0200] - import userRoot: Import complete.  Processed 9523 entries in 7 seconds. (1360.43 entries/sec)
[25/Aug/2010:18:34:40 +0200] NSMMReplicationPlugin - multimaster_be_state_change: replica dc=id,dc=polytechnique,dc=edu is coming online; enabling replication

But  when i continue and try to make a change on a master the consumer
server  crashes.  So the total replica initialisation is ok but even a
single  incremental  update  crashes the consumer server. And there is
nothing  helpful  in logs. I haven't tried the 1.2.6.rc7 version, i've
tried  the latest code version (as of today). Don't know if it matters
(there  seem  to  be  a  lot  of coverity defects that have been fixed
between rc7 and a1).
Can you get a core file and a stack trace?
Rich, just as i thought, this crash happens only with today's snapshot of 1.2.7.a1 version only. I've compiled 1.2.6.rc7 and the replication works smoothly and without any problem. I didn't have a lot of time to generate a stack trace because i was migrating our production servers. I thought the latest build should be stable but it seems that the changes between 6rc7 and 7a1 introduce some problems with incremental replication as well as with apostrophs in DN (my second mail). So for now i will migrate to 1.2.6.rc7. I'll test the a1 version later when i will have time...