On 11/6/19 12:42 AM, Grant Byers wrote:

Hi,

Iíve mostly completed automated deployment of a 389ds cluster via Ansible. The final piece of the puzzle is the enablement of SSL/TLS for the Admin server. †From what I understand, I should be able to use the sec-activate tool to do this;

/usr/lib64/dirsrv/cgi-bin/sec-activate /etc/dirsrv/admin-serv on

What I canít figure out is how to authenticate. When I run this, it prompts me repeatedly for ňnter Admin Server Administrator password:Ē. I have tried both the RootDN and ConfigDirectoryAdminPwd passwords, but neither seem to work.

Can anyone suggest whatís going on here & how I might get past it?


I have never used, or heard of anyone using, sec-activate to enable SSL in the admin server.† I suggest following the official documentation on setting this up using certutil and a password/pin file:

https://access.redhat.com/documentation/en-us/red_hat_directory_server/10/html/administration_guide/enabling_tls#enabling_tls_in_the_administration_server

HTH,

Mark



Thanks,

Grant


_______________________________________________
389-users mailing list -- 389-users@lists.fedoraproject.org
To unsubscribe send an email to 389-users-leave@lists.fedoraproject.org
Fedora Code of Conduct: https://docs.fedoraproject.org/en-US/project/code-of-conduct/
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/389-users@lists.fedoraproject.org
-- 

389 Directory Server Development Team