Bad name of App property queue. The name needs to be queue_instance. Fix import queue as queue :)
*Resolves: rhbz#1243316*
From: Jiri Konecny jkonecny@redhat.com
Bad name of App property queue. The name needs to be queue_instance. Fix import queue as queue :)
Resolves: rhbz#1243316 --- pyanaconda/ui/tui/__init__.py | 6 +++--- 1 file changed, 3 insertions(+), 3 deletions(-)
diff --git a/pyanaconda/ui/tui/__init__.py b/pyanaconda/ui/tui/__init__.py index 4c5b93c..585515e 100644 --- a/pyanaconda/ui/tui/__init__.py +++ b/pyanaconda/ui/tui/__init__.py @@ -31,7 +31,7 @@ import os import sys import site -import queue as queue +import queue import meh.ui.text import logging log = logging.getLogger("anaconda") @@ -204,8 +204,8 @@ def _send_show_message(self, msg_fn, args, ret_queue):
"""
- self._app.queue.put((hubQ.HUB_CODE_SHOW_MESSAGE, - [msg_fn, args, ret_queue])) + self._app.queue_instance.put((hubQ.HUB_CODE_SHOW_MESSAGE, + [msg_fn, args, ret_queue]))
def _handle_show_message(self, event, data): """
Added label: master.
This looks good to me.
Added label: ACK.
This is why I just call it "q" elsewhere in anaconda. The two are pronounced the same way.
Pushed. Thank you
Closed.
anaconda-patches@lists.fedorahosted.org