On Fri, Jul 19, 2013 at 1:03 PM, Jon <jdisnard@gmail.com> wrote:
Here are my notes on MiraBox.
(These are adapted from Jon Masters)

Thanks for posting these!  I'm still not able to get them to work -- maybe someone on the list can tell me what I'm doing wrong.  I started by downloading Fedora-Minimal-armhfp-19-1-sda.raw.xz, finding that the micro-sd card was showing up as /dev/sdb on my system, and then doing (as root):

xzcat Fedora-Minimal-armhfp-19-1-sda.raw.xz > /dev/sdb

After the light on the SD card reader stopped blinking, I ran "sync" a couple of times to ensure that the data had all been written.  I then examine the SD card -- it had three partitions: a boot partition, a swap partition, and a root partition.  Everything looked in order so far.

[jon@shambhala ~]$ cat mira-notes.txt

# change to the boot directory on the rootfs
# all paths are relative to the boot partition.

cat vmlinuz-${version}.armv7hl \
    dtb-${version}.armv7hl/armada-370-mirabox.dtb > \

mkimage -A arm -O linux -T kernel -C none \
        -a 0x00008000 -e 0x00008000 \
        -n "${version}.armv7hl.mirabox-adtb" \
        -d vmlinuz-${version}.armv7hl.mirabox-adtb \

/bin/cp -f uImage-${version}.armv7hl.mirabox-adtb uImage
/bin/cp -f uInitrd-${version}.armv7hl uInitrd

I followed all of these commands, and created the new uImage with the appended dtb.  So far so good.
# bellow are the u-boot commands

setenv bootcmd 'usb start; ext2load usb 1:1 0x02000000 uImage;
ext2load usb 1:1 0x02800000 uInitrd; bootm 0x02000000 0x02800000'
setenv bootargs 'ro rootwait earlyprintk debug root=/dev/sdb3
run bootcmd

This is where I ran into problems.  When I run the "ext2load usb 1:1" command, I get an error message:

Marvell>> ext2load usb 1:1 0x02000000 uImage
** Bad partition 1 **

Any idea why I'd be getting a "bad partition" message?  Here's the output of parted on the SD card:

[root@hockey ISO]# parted /dev/sdb print
Model: USB Mass Storage Device (scsi)
Disk /dev/sdb: 15.7GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End     Size    Type     File system     Flags
 1      1000kB  513MB   512MB   primary  ext3            boot
 2      513MB   1025MB  512MB   primary  linux-swap(v1)
 3      1025MB  15.7GB  14.7GB  primary  ext4

I'll continue to fiddle with this again today.

Jared Smith