On 7/21/2013 11:17, Jared K. Smith wrote:
# bellow are the u-boot commands

setenv bootcmd 'usb start; ext2load usb 1:1 0x02000000 uImage;
ext2load usb 1:1 0x02800000 uInitrd; bootm 0x02000000 0x02800000'
setenv bootargs 'ro rootwait earlyprintk debug root=/dev/sdb3
run bootcmd

This is where I ran into problems.  When I run the "ext2load usb 1:1" command, I get an error message:

Marvell>> ext2load usb 1:1 0x02000000 uImage
** Bad partition 1 **

What's the output you get from "usb start" ? Should be someting like

Marvell>> usb start
(Re)start USB...
USB:   Active port:     invalid port number 2, switching to port 0
Register 10011 NbrPorts 1
scanning bus for devices... 4 USB Device(s) found
Waiting for storage device(s) to settle before scanning...
       scanning bus for storage devices... Device NOT ready
   Request Sense returned 02 3A 00
2 Storage Device(s) found

Does it see your sd card as device 1? i.e.

Marvell>> usb storage
  Device 0: Vendor: Generic  Rev: 9451 Prod: STORAGE DEVICE
            Type: Removable Hard Disk
            Capacity: not available
  Device 1: Vendor: Generic  Rev: 9451 Prod: STORAGE DEVICE
            Type: Removable Hard Disk
            Capacity: 15407.0 MB = 15.0 GB (31553536 x 512)

And does u-boot see the partitions?

Marvell>> usb part 1
print_part of 1

Partition Map for USB device 1  --   Partition Type: DOS

Partition     Start Sector     Num Sectors     Type
    1                 1953         1000001      83
    2              1001954         1000000      83
    3              2001954        12695312      83


Any idea why I'd be getting a "bad partition" message?  Here's the output of parted on the SD card:

[root@hockey ISO]# parted /dev/sdb print
Model: USB Mass Storage Device (scsi)
Disk /dev/sdb: 15.7GB
Sector size (logical/physical): 512B/512B
Partition Table: msdos
Disk Flags:

Number  Start   End     Size    Type     File system     Flags
 1      1000kB  513MB   512MB   primary  ext3            boot
 2      513MB   1025MB  512MB   primary  linux-swap(v1)
 3      1025MB  15.7GB  14.7GB  primary  ext4

I'll continue to fiddle with this again today.

Jared Smith

arm mailing list