So, I had koji running and building packages for me for nearly a
fortnight. And it worked like a charm!

I double-checked all the configuration and it is intact. There is the
and entry in pg_hba.conf that trusts koji.

I run psql command from the "koji" user on the same machine where
koji-hub is running. So, psql uses the default values for DBName and
DBUser. (which are "koji" and "koji" respectively) (And I don't use the
host option). Also, I've checked that DBName and DBUser configuration
are OK in the kojihub.conf

On a different note, how does one debug a script which uses rpc calls
and the error is on the server side? i.e. the debugger will run on the
caller side, so, how do we debug the script that is executed on the
server? (Except inserting write-to-file commands in the server script)
Also, does koji maintain a logfile?... I wasn't able find it anywhere.


On Thu, 2009-01-22 at 08:45 +0100, Oliver Falk wrote:
> Jitesh Shah wrote:
> > So, this morning I moved to a newer version of koji. Reconfigured
> > everything (restarted apache after re-configuring koji-hub) and quite
> > surprisingly, I still get the same error!
> >
> > So, if reinitialising both, postgresql and koji, doesn't do the trick, I
> > wonder what might have gone wrong.
> > (Just as a matter of curiosity, I even checked with ipcs that there are
> > no dangling shared memory segments. There aren't any.)
> The settings in /etc/httpd/conf.d/kojihub.conf are correct I guess?
> Esp. DBName, DBUser, DBHost? And your /var/lib/pgsql/data/pg_hba.conf is
> also OK?
> And you can connect via command line? psql -U <DBUser> -h <DBHost> <DBName>?
> The error is quite clear. kojihub is not able to connect to the
> database, so something is wrong with the config... :-(
> -of
> --
> Fedora-buildsys-list mailing list
> Fedora-buildsys-list@redhat.com
> https://www.redhat.com/mailman/listinfo/fedora-buildsys-list