Thank you for the quick reply Oliver.

So, this morning I moved to a newer version of koji. Reconfigured
everything (restarted apache after re-configuring koji-hub) and quite
surprisingly, I still get the same error!

So, if reinitialising both, postgresql and koji, doesn't do the trick, I
wonder what might have gone wrong.
(Just as a matter of curiosity, I even checked with ipcs that there are
no dangling shared memory segments. There aren't any.)


On Thu, 2009-01-22 at 08:16 +0100, Oliver Falk wrote:
> Hi Jitesh!
> Jitesh Shah wrote:
> > Hi,
> > I've been running a local koji instance at my workplace. It worked
> > absolutely fine for a fortnight. But, since Monday, I am getting this
> > error : "ServerOffline: database outage" for any CLI command that I try
> > to execute.
> >
> > I initially suspected that it might be because koji cannot connect to
> > the database. But, I checked that I can login to the database through
> > command-line.
> >  >> psql
> >
> > Also, I wrote a small script in python which mimics koji's method of
> > connecting to the database (with reference
> > to /usr/lib/python2.5/site-packages/koji/db.py) and it works fine!
> >
> > Just to make sure, I restarted postgresql service in vain.
> > Re-initialised the database (Remove /var/lib/pgsql and run "service
> > postgresql initdb" and all the other steps) to no avail.
> >
> > I started seeing this problem after a run of the koji-shadow script. It
> > exited abnormally giving this very error. Since then, I cannot even
> > access koji-cli.. neither koji-web.
> >
> > I have been tracing through the koji scripts and I see that the SSL
> > login succeeds and then the very first rpc call: "getAPIVersion" fails.
> > Wireshark shows that the koji-hub replies with "Connection: close" to
> > the getAPIVersion call.
> >
> > Any idea as to what is going wrong?
> > Any pointers?
> You have not written if you have tried to restart Apache. koji(hub) has
> no auto-reconnect if it looses connection to the database. So if for
> whatever reason it lost the connection to PostgreSQL, it will never
> reconnect. You have to manually restart Apache!
> -of
> --
> Fedora-buildsys-list mailing list
> Fedora-buildsys-list@redhat.com
> https://www.redhat.com/mailman/listinfo/fedora-buildsys-list