Yes, I can successfully connect to the psql database using tcp sockets
too. Here is the snippet of the interaction in the terminal.

[koji@linux-dev ~]$ psql -U koji -h localhost -d koji
Welcome to psql 8.2.11, the PostgreSQL interactive terminal.

Type:  \copyright for distribution terms
       \h for help with SQL commands
       \? for help with psql commands
       \g or terminate with semicolon to execute query
       \q to quit


I can view all the tables with "\d". So, it is connected all-right. Btw,
I also checked in the "users" "permissions" and "user_perms" tables to
verify that "koji" user is indeed the "admin" and has all the required


On Thu, 2009-01-22 at 02:18 -0800, Toshio Kuratomi wrote:
> Jitesh Shah wrote:
> > Hi,
> > So, I had koji running and building packages for me for nearly a
> > fortnight. And it worked like a charm!
> >
> > I double-checked all the configuration and it is intact. There is the
> > and entry in pg_hba.conf that trusts koji.
> >
> > I run psql command from the "koji" user on the same machine where
> > koji-hub is running. So, psql uses the default values for DBName and
> > DBUser. (which are "koji" and "koji" respectively) (And I don't use the
> > host option). Also, I've checked that DBName and DBUser configuration
> > are OK in the kojihub.conf
> >
> It sounds like you're running the koji db on the same machine as the
> kojihub?  Just to be sure you're testing the same thing with psql as
> koji is going to run, try  psql with the -h HOST option.  The reason is
> that psql without the -h will try to use unix sockets to connect on the
> local machine.  koji, though, is going to use a tcp connection, not a
> socket.
> -Toshio
> --
> Fedora-buildsys-list mailing list
> Fedora-buildsys-list@redhat.com
> https://www.redhat.com/mailman/listinfo/fedora-buildsys-list