I keep having problems with it telling me the system is locked until I run a restart, but service kojid status keeps returning the same error

service kojid status
kojid dead but subsys locked

kojid also seems to be dying but the logs yield no real data

I think I have a problem in my configs:


; The number of seconds to sleep between tasks
; sleeptime=15

; The maximum number of jobs that kojid will handle at a time
; maxjobs=10

; The minimum amount of free space (in MBs) required for each build root
; minspace=8192

; The directory root where work data can be found from the koji hub
; topdir=/mnt/koji

; The directory root for temporary storage

; The directory root for mock

; The user to run as when doing builds

; The vendor to use in rpm headers
; vendor=Koji

; The packager to use in rpm headers
; packager=Koji

; The _host string to use in mock
; mockhost=koji-linux-gnu

; The URL for the xmlrpc server


; The URL for the packages tree

; A space-separated list of hostname:repository[:use_common] tuples that kojid is authorized to checkout from (no quotes).
; Wildcards (as supported by fnmatch) are allowed.
; If use_common is specified and is one of "false", "no", or "0" (without quotes), then kojid will not attempt to checkout
; a common/ dir when checking out sources from the source control system.  Otherwise, it will attempt to checkout a common/
; dir, and will raise an exception if it cannot.
;allowed_scms=scm.example.com:/cvs/example git.example.org:/example svn.example.org:/users/*:no

; The mail host to use for sending email notifications

; The From address used when sending email notifications
from_addr=Koji Build System <koji@koji.bcinfra.net>

;configuration for SSL athentication

;client certificate
cert = /etc/pki/koji/kojibuilder1.pem

;certificate of the CA that issued the client certificate
ca = /etc/pki/koji/koji_ca_cert.crt

;certificate of the CA that issued the HTTP server certificate
serverca = /etc/pki/koji/koji_ca_cert.crt

On Thu, Feb 26, 2009 at 10:32 AM, Jeffrey Ollie <jeff@ocjtech.us> wrote:
On Thu, Feb 26, 2009 at 11:29 AM, Thomas Hatch <thatch65@gmail.com> wrote:
> I run "koji list-hosts --channel=createrepo" and get:
> Hostname                     Enb Rdy Load/Cap Arches           Last Update
> koji.bcinfra.net             Y   N    0.0/8.0 i386,x86_64      -
> Seems it is enabled and in the channel, but not ready?

Is kojid running?  That's the service that does the actual building...

Jeff Ollie
Marcus to Franklin in Babylon 5: "A Late Delivery from Avalon"