Discussion topic:
With the recent changes to mock, several default config file options have changed. I am of the opinion that we should provide a config file with only the basic things that the user would like to change, and leave the defaults in mock.py (with an option to dump the config). For example, I believe we should take out the mount, unmount, rm, chroot, etc from our default configs, as it is highly unlikely that average users would change these.
The reason for this proposed change is to make it easier to migrate from one version to the next. As it is, mock 0.7 will not be able to use %config(noreplace) on the config files, because too many things changed. The user will have to manually merge any site-specific changes.
The final config file, I believe, should only contain the yum config relating to repository locations, which the user is likely to want to mirror for speed reasons.
Comments? -- Michael
-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1
Michael_E_Brown@Dell.com wrote:
Default config file contents
Discussion topic:
With the recent changes to mock, several default config file options have changed. I am of the opinion that we should provide a config file with only the basic things that the user would like to change, and leave the defaults in mock.py (with an option to dump the config). For example, I believe we should take out the mount, unmount, rm, chroot, etc from our default configs, as it is highly unlikely that average users would change these.
The reason for this proposed change is to make it easier to migrate from one version to the next. As it is, mock 0.7 will not be able to use %config(noreplace) on the config files, because too many things changed. The user will have to manually merge any site-specific changes.
The final config file, I believe, should only contain the yum config relating to repository locations, which the user is likely to want to mirror for speed reasons.
Comments?
I agree. Sounds like we'll end up with a file that only contains options that modify behavior, as opposed to basic utilities. Possibly the following:
config_opts['basedir'] = '/var/lib/mock/' config_opts['chrootuser'] = 'mockbuild' config_opts['chrootgroup'] = 'mockbuild' config_opts['chroothome'] = '/builddir' config_opts['clean'] = True
# caching related options config_opts['rebuild_cache'] = True config_opts['use_cache'] = True config_opts['cache_topdir'] = "root-cache" config_opts['max_cache_age_days'] = 15
My only addition would be to say that I'd really like a better name than "defaults.cfg", which is one letter removed from the symlink default.cfg, which is the default configuration file. I don't really have a preference, just something not so easily confused.
Maybe "configuration.cfg" or something like that?
Clark
On Mon, 2006-06-26 at 17:21 -0500, Clark Williams wrote:
Maybe "configuration.cfg" or something like that?
+1 to a more simple config file. The easier the better, and the less to worry about when upgrading.
As far as a name, mock-config.cfg ? setup.cfg ? I agree it is to close to 'default.cfg'.
buildsys@lists.fedoraproject.org