vgoyal added a new comment to an issue you are following:
I would vote that we keep it easy for the user. Why don't we have
CONTAINER_ROOT_VOLUME=yes instead of DOCKER_ROOT_VOLUME=yes.
Problem with that is that we don't know where to mount the volume after creation.
Right now, we mount it on /var/lib/docker. Also we scan /etc/sysconfig/docker for option
-g and try to mount it
there. But all that soon becomes very specific to docker.
Hence, instead we wanted user to pass in the directory where volume should be mounted. And
if user is passing in directory, that itself means create extra volume.
I was thinking that EXTRA_VOLUME_MOUNT_DIR is more generic because we don't care how
container runtime uses it. Whether it is their ROOT or they use it to carve out volumes or
something else. That's the reason I suggested that instead this naming scheme. But I
am not too particular and I will be fine with CONTAINER_ROOT_VOLUME_MOUNT_DIR as well.
Dusty, shishir has created a new PR for this change. Feel free to review it.
You can still have variables like EXTRA_VOLUME_NAME and
EXTRA_VOLUME_MOUNT_DIR but just make them have default values that only need to be
specified if the user doesn't like the defaults.
By default these will be nil. That is no extra volume will be set. Users will have to
specify values if
they want extra volume to be set.
small nit: I would rather have them be CONTAINER_VOLUME_NAME and
I am fine with above naming.
take it a step farther back and we should call it container storage
That's the plan. We are doing changes slowly and ultimately will rename it to
To reply, visit the link below or just reply to this email