On Sat, Mar 2, 2019 at 9:23 AM Adam Williamson <adamwill@fedoraproject.org> wrote:
>
> This is a known issue. I'm stuck in dependency hell right now. Current
> FreeCAD needs Python 2 packages (and a couple of other FTBFS packages from
> f30). The pre-release of the next version has changed over to Python 3 but
> also requires PySide2 which is not in Fedora. I'm working on it as I have
> time.

Any Python 2 packages that FreeCAD required should not have been
retired, under the policy (you're not supposed to retire them until
nothing uses them any more, AIUI). You could ask for them to be
resurrected on this basis, I guess.

Just tried to rebuild, vtk-devel has moved to qt5 but the current release of freecad still needs qt4. My best bet it to wait until the new qt 5.12 (and related) packages are in f30/31, get PySIde2 in Fedora, and build the pre-release.

Thanks,
Richard