I have signed the packages and updated my repo. I have also created a rpm to install the repo config and the gpg pub key.

yum install http://www.edmann.com/Enlightenment/repo/Fedora/17/x86_64/RPMS/enlightenment-repo-0.0.2-1.fc17.x86_64.rpm

I also built a new 17 test machine to test out the install and found that selinux will prevent enlightenment from starting up on the initial startup. I put it in permissive mode and it was able to start. I put it back to enforcing and it worked fine, then restarted with it in default enforcing and i was still able to get into e17.


I am building 386 and x86_64 fedora 18 beta machines and will run the builds on those as well. I will update with the new repos.

For libeio i ran yum install enlightenment eio and it pulled the package from my repo. I will do some more testing on this with the 18 boxes.



On , Rudolf Kastl wrote:

the crash happens because of a collision with libeio which is in the fedora main repository.

2012/11/29 Rudolf Kastl <che666@gmail.com>
After yum install enlightenment running enlightenment_start makes it crash:
E - PID=22138, valgrind=0
/usr/bin/enlightenment: symbol lookup error: /usr/lib64/libedje.so.1: undefined symbol: EIO_MONITOR_FILE_CREATED

2012/11/29 Rudolf Kastl <che666@gmail.com>
Another comment: while you keep that repository up id really welcome if you could sign the packages in your private repo.

2012/11/29 Rudolf Kastl <che666@gmail.com>
Actually the baseurl provided in your paste does not work for me.

here is the fixed entry: baseurl=http://www.edmann.com/Enlightenment/repo/Fedora/$releasever/x86_64/RPMS

2012/11/29 Edward Mann <e.dev@edmann.com>

On , Tom Callaway wrote:

On 11/27/2012 02:47 PM, Edward Mann wrote:
I would like to be the maintainer for the Enlightenment e17 for Fedora. I am sending this e-mail to seek guidance and also a sponsor. Getting e17 on Fedora i will need to build and install the following packages eina - Core data structure library.
In Fedora as "libeina" (I own it)
eet - Data encode/decode and storage library.
In Fedora as "eet" (I own it)
evas - Canvas and scenegraph rendering library.
In Fedora as "evas" (I own it)
ecore - Core mainloop, display abstraction and utility library.
In Fedora as "ecore" (I own it)
embryo - Small Pawn based virtual machine and compiler. edje - Abstract GUI layout and animation object library. efreet - Standards handling for freedesktop.org standards. e_dbus - Dbus wrapping and glue layer library. eeze - Device abstraction library. elementary - Elementary, the widget set... emotion - Emotion, video and audio codec API... ethumb - EThumb, thumbnail generation library... eio - Eio, async I/O library...
I don't think any of these are in Fedora, so they'd be a great place to
start. Let me know if you need any changes to the four packages I own,
once you get in the packager group, I'd be happy to let you comaintain them.


Fedora Project

Thanks for the response Tom. I had searched the packages, however i realized i needed to go one more page in the package list to find those that you own. E17 currently needs all packages to be at the 1.7.2 release. The Enlightenment team plans on keeping them all at the same version number even if some packages have no changes. You probably already know this.


I think i remember removing libeina when i installed my build of eina. If we can get libeina up to 1.7.2 then i will adjust the packages to look for libeina and not eina.

I have all the packages up on my website http://www.edmann.com/Enlightenment/repo/Fedora/17/

Also i have the yum repo

name=Enlightenment for Fedora $releasever
[Enlightenment - Sources]
name=Enlightenment SRPMS for Fedora $releasever

Right now it's only for x86_64, i will build another vm and do  i386 packages. Not sure if that will be needed, but people might come across it and want those. I will also do 18 beta as well.


Do i need to make a bug request for each package or is that premature for me to do right now?