On 2/1/19 2:37 PM, Björn 'besser82' Esser wrote:
Am Freitag, den 01.02.2019, 13:30 +0100 schrieb Zdenek Dohnal:
On 2/1/19 12:21 PM, Jan Synacek wrote:
On Thu, Jan 31, 2019 at 11:19 PM Richard W.M. Jones <
rjones@redhat.com> wrote:
emacs isn't installable at the moment, so any package that needs
emacs
fails to build, eg:

https://koji.fedoraproject.org/koji/taskinfo?taskID=32380321

DEBUG util.py:490: BUILDSTDERR: Error:
DEBUG util.py:490: BUILDSTDERR: Problem: package emacs-1:26.1-
7.fc30.x86_64 requires libMagickCore-6.Q16.so.6()(64bit), but none
of the providers can be installed
DEBUG util.py:490: BUILDSTDERR: - package emacs-1:26.1-7.fc30.x86_64 
requires libMagickWand-6.Q16.so.6()(64bit), but none of the
providers can be installed
DEBUG util.py:490: BUILDSTDERR: - conflicting requests
DEBUG util.py:490: BUILDSTDERR: - nothing provides libwmflite-
0.2.so.7()(64bit) needed by ImageMagick-libs-1:6.9.10.23-
1.fc30.x86_64

Looks like a broken ImageMagick to me.
 IMO it is unannounced soname bump of libwmflite and libwmf and it is
even in F29 - it broke my gutenprint build too (because gutenprint has
dependency on gimp, which is broken by unannounced soname bump) 
https://koji.fedoraproject.org/koji/taskinfo?taskID=32416632 .

I've untagged the buildroot-override for libwmf in f29.  Your build
should be fine again in about 15 minutes or so.
Thank you, Björn!

      
_______________________________________________
devel mailing list -- devel@lists.fedoraproject.org
To unsubscribe send an email to devel-leave@lists.fedoraproject.org
Fedora Code of Conduct: https://getfedora.org/code-of-conduct.html
List Guidelines: https://fedoraproject.org/wiki/Mailing_list_guidelines
List Archives: https://lists.fedoraproject.org/archives/list/devel@lists.fedoraproject.org
-- 
Zdenek Dohnal
Associate Software Engineer
Red Hat Czech - Brno TPB-C