I pulled it (updating existing checkout) about 10 hours ago with no issues. 

- Josh

~ Kirtan is Life! ~
Sent from my iPhone.

On 28/06/2011, at 8:07 PM, Nathan Thomas <nathan@afternoondust.co.uk> wrote:

Hi guys,

Today I tried pulling from the git repo for docs.fp.org and got the following error:

$ git pull
remote: Counting objects: 1667, done.
remote: Compressing objects: 100% (267/267), done.
remote: Total 1240 (delta 1208), reused 1005 (delta 973)
Receiving objects: 100% (1240/1240), 1.07 MiB | 194 KiB/s, done.
Resolving deltas: 100% (1208/1208), completed with 422 local objects.
>From ssh://git.fedorahosted.org/git/docs/web
   e33bdff..ab174ad  master     -> origin/master
error: bad index file sha1 signature
fatal: index file corrupt

I tried to clone a fresh copy of the repo, but that failed too:

$ git clone ssh://nathant@git.fedorahosted.org/git/docs/web.git web
Cloning into web...
remote: Counting objects: 154218, done.
remote: Compressing objects: 100% (27484/27484), done.
remote: Total 154218 (delta 131127), reused 147625 (delta 124561)
Receiving objects: 100% (154218/154218), 1.43 GiB | 873 KiB/s, done.
error: inflate: data stream error (incorrect data check)
fatal: serious inflate inconsistency
fatal: index-pack failed

Last successful pull was about a week or so ago. Anyone have any ideas?


! Please note my new email address !
My blog: http://afternoondust.wordpress.com
Twitter: nlt_1840
docs mailing list
To unsubscribe: