On Thu, Nov 10, 2022 at 3:11 PM <email@example.com> wrote:
> I have 2 systems running el8. When I run yum update qt5-qtbase I get the
> following error on both systems:
> (tom-lp-21 pts7) # yum update qt5-qtbase
> Updating Subscription Management repositories.
> Last metadata expiration check: 0:01:52 ago on Thu 10 Nov 2022 03:02:34 PM EST.
> Problem: problem with installed package kf5-kxmlgui-5.88.0-1.el8.x86_64
> - package kf5-kxmlgui-5.88.0-1.el8.x86_64 requires libQt5Core.so.5(Qt_5.15.2_PRIVATE_API)(64bit), but none of the providers can be installed
> - package kf5-kxmlgui-5.88.0-1.el8.x86_64 requires qt5-qtbase(x86-64) = 5.15.2, but none of the providers can be installed
> - cannot install both qt5-qtbase-5.15.3-1.el8.x86_64 and qt5-qtbase-5.15.2-4.el8.x86_64
> - cannot install both qt5-qtbase-5.15.3-1.el8.x86_64 and qt5-qtbase-5.15.2-3.el8.x86_64
> - cannot install the best update candidate for package qt5-qtbase-5.15.2-4.el8.x86_64
> (try to add '--allowerasing' to command line to replace conflicting packages or '--skip-broken' to skip uninstallable packages or '--nobest' to use not only best candidate packages)
> (tom-lp-21 pts7) #
> Does anyone know how to resolve this?
The KDE stack needs to be rebuilt against the new Qt 5.15.3 shipped
with RHEL 8.7. I'm pretty sure Troy is on the case for that. But if
you need to work around it, you can install epel-next-release and use
its repos to upgrade properly for now.
Please don't use the epel-next release repo.
Will it work? yes. Will it confuse things? yes
Please do the following for a week.
dnf --exclude=qt5* update
RHEL 8.7 came out this week. It has an updated qt5-qtbase.
As Neal said, this means that KDE had to be rebuilt.
I am also taking this opportunity to update KDE, not to the latest, but to the latest that RHEL 8 libraries will allow me to.
I expect the update to be in epel-testing tomorrow.
I currently have about 350 packages rebuilt, 10 to go.