On 2017-02-13 04:51, Sérgio Basto wrote:
perl-Git-Wrapper.spec doesn't build in EPEL7 because :
BuildRequires: perl(:VERSION) >= 5.6
DEBUG util.py:435: No matching package to install: 'perl(:VERSION) >=
perl -v :
This is perl 5, version 16, subversion 3 (v5.16.3)
If you need to limit your package to a specific Perl version, use
perl(:VERSION) dependency with desired version constraint (e.g.
perl(:VERSION) >= 5.22).
But Perl 5.6.0 is a version from year 2000, so it is safe comment this
"BuildRequires", but anyone know a better solution ?
The perl(:VERSION) provide only works in Fedora at the moment so you
can't use it in EPEL. Given that even EPEL-5 has perl 5.8.8 I wouldn't
worry about the version requirement, but you should retain a build
dependency on "perl" itself (not necessarily versioned) as it'll be
needed for the package build process.