https://bugzilla.redhat.com/show_bug.cgi?id=1113601
Bug ID: 1113601 Summary: When kernel is installed as a dependency of autofs, various errors are shown Product: Fedora Version: 20 Component: docker-io Assignee: lsm5@switzerlandmail.ch Reporter: jpazdziora@redhat.com QA Contact: extras-qa@fedoraproject.org CC: admiller@redhat.com, golang@lists.fedoraproject.org, hushan.jia@gmail.com, lsm5@switzerlandmail.ch, mattdm@redhat.com, mgoldman@redhat.com, s@shk.io, vbatts@redhat.com
Description of problem:
When kernel is installed as a dependency of autofs, various errors concerning /var are shown in posttrans.
Version-Release number of selected component (if applicable):
docker-io-1.0.0-4.fc20.x86_64 fedora:20 image as of today: 3f2fed40e4b0
How reproducible:
Deterministic.
Steps to Reproduce: 1. Have Dockerfile:
FROM fedora:20 RUN yum install -y autofs
2. Run docker build -t autofs-test .
Actual results:
# docker build -t autofs-test . Sending build context to Docker daemon 2.56 kB Sending build context to Docker daemon Step 0 : FROM fedora:20 ---> 3f2fed40e4b0 Step 1 : RUN yum install -y autofs ---> Running in 9b0bbf2f654d http://mirrors.zimcom.net/pub/fedora/linux/updates/20/x86_64/repodata/repomd...: [Errno 14] curl#7 - "Failed to connect to 2607:f550:100:33::23: Network is unreachable" Trying other mirror. Resolving Dependencies --> Running transaction check ---> Package autofs.x86_64 1:5.0.7-40.fc20 will be installed --> Processing Dependency: kernel >= 2.6.17 for package: 1:autofs-5.0.7-40.fc20.x86_64 --> Processing Dependency: libtirpc.so.1()(64bit) for package: 1:autofs-5.0.7-40.fc20.x86_64 --> Processing Dependency: libhesiod.so.0()(64bit) for package: 1:autofs-5.0.7-40.fc20.x86_64 --> Running transaction check ---> Package hesiod.x86_64 0:3.2.1-2.fc20 will be installed ---> Package kernel.x86_64 0:3.14.8-200.fc20 will be installed --> Processing Dependency: linux-firmware >= 20130724-29.git31f6b30 for package: kernel-3.14.8-200.fc20.x86_64 ---> Package libtirpc.x86_64 0:0.2.4-3.0.fc20 will be installed --> Running transaction check ---> Package linux-firmware.noarch 0:20140605-38.gita4f3bc03.fc20 will be installed --> Finished Dependency Resolution
Dependencies Resolved
================================================================================ Package Arch Version Repository Size ================================================================================ Installing: autofs x86_64 1:5.0.7-40.fc20 updates 524 k Installing for dependencies: hesiod x86_64 3.2.1-2.fc20 fedora 29 k kernel x86_64 3.14.8-200.fc20 updates 32 M libtirpc x86_64 0.2.4-3.0.fc20 updates 83 k linux-firmware noarch 20140605-38.gita4f3bc03.fc20 updates 21 M
Transaction Summary ================================================================================ Install 1 Package (+4 Dependent packages)
Total download size: 53 M Installed size: 192 M Downloading packages: Delta RPMs disabled because /usr/bin/applydeltarpm not installed. warning: /var/cache/yum/x86_64/20/fedora/packages/hesiod-3.2.1-2.fc20.x86_64.rpm: Header V3 RSA/SHA256 Signature, key ID 246110c1: NOKEY Public key for hesiod-3.2.1-2.fc20.x86_64.rpm is not installed Public key for autofs-5.0.7-40.fc20.x86_64.rpm is not installed -------------------------------------------------------------------------------- Total 4.0 MB/s | 53 MB 00:13 Retrieving key from file:///etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-20-x86_64 Importing GPG key 0x246110C1: Userid : "Fedora (20) fedora@fedoraproject.org" Fingerprint: c7c9 a9c8 9153 f201 83ce 7cba 2eb1 61fa 2461 10c1 Package : fedora-release-20-3.noarch (@fedora-updates/$releasever) From : /etc/pki/rpm-gpg/RPM-GPG-KEY-fedora-20-x86_64 Running transaction check Running transaction test Transaction test succeeded Running transaction Installing : hesiod-3.2.1-2.fc20.x86_64 1/5 Installing : libtirpc-0.2.4-3.0.fc20.x86_64 2/5 Installing : linux-firmware-20140605-38.gita4f3bc03.fc20.noarch 3/5 Installing : kernel-3.14.8-200.fc20.x86_64 4/5 Installing : 1:autofs-5.0.7-40.fc20.x86_64 5/5 No '/dev/log' or 'logger' included for syslog logging mknod: '/var/tmp/initramfs.aD5A0T/dev/null': Operation not permitted mknod: '/var/tmp/initramfs.aD5A0T/dev/kmsg': Operation not permitted mknod: '/var/tmp/initramfs.aD5A0T/dev/console': Operation not permitted No '/dev/log' or 'logger' included for syslog logging mknod: '/var/tmp/initramfs.XRmzzi/dev/null': Operation not permitted mknod: '/var/tmp/initramfs.XRmzzi/dev/kmsg': Operation not permitted mknod: '/var/tmp/initramfs.XRmzzi/dev/console': Operation not permitted /usr/lib/kernel/install.d/51-dracut-rescue.install: line 59: /boot/loader/entries/5b2a1f96231d4de69964798a33d2add8-0-rescue.conf: No such file or directory warning: %posttrans(kernel-3.14.8-200.fc20.x86_64) scriptlet failed, exit status 1 Non-fatal POSTTRANS scriptlet failure in rpm package kernel-3.14.8-200.fc20.x86_64 Verifying : 1:autofs-5.0.7-40.fc20.x86_64 1/5 Verifying : linux-firmware-20140605-38.gita4f3bc03.fc20.noarch 2/5 Verifying : libtirpc-0.2.4-3.0.fc20.x86_64 3/5 Verifying : hesiod-3.2.1-2.fc20.x86_64 4/5 Verifying : kernel-3.14.8-200.fc20.x86_64 5/5
Installed: autofs.x86_64 1:5.0.7-40.fc20
Dependency Installed: hesiod.x86_64 0:3.2.1-2.fc20 kernel.x86_64 0:3.14.8-200.fc20 libtirpc.x86_64 0:0.2.4-3.0.fc20 linux-firmware.noarch 0:20140605-38.gita4f3bc03.fc20
Complete! ---> e11ccfbfb8a0 Removing intermediate container 9b0bbf2f654d Successfully built e11ccfbfb8a0
Expected results:
Either kernel not pulled in, or no (or less) errors from posttrans.
Additional info:
Using docker-io component as a start of discussion about supporting autofs in Docker containers and if something can be changed in packaging of autofs or kernel or in the fedora:20 image to lower the posttrans noise.