https://bugzilla.redhat.com/show_bug.cgi?id=1098120
--- Comment #4 from Daniel Walsh dwalsh@redhat.com --- The problem is the libselinux in the centos image is reporting that SELinux is enabled to processes running within the container. This is tools like useradd and groupadd to attempt to write to /proc/self/attr/* files in order to setup proper labeling for SELinux. Since /proc is now mounted read/only within the container, the writes are denied and useradd/groupadd fail.
The fix is to get an updated version of libselinux into the Centos 6 images. RHEL7/RHEL6 and Current Fedora images have the fix.
Privileged containers and systems with SELInux disabled will not have this issue.
I believe the Fedora bugs reported are a separate issue, and it looks like the postgresql user needs to be added.