iptraf-ng 1.1.4
by Nikola Pajkovsky
So it's been quite long time that I was released any new versions.
Token-ring was killed, ifstats, servmon and packet_size_breakdown has
got some nice optimization and of course there bunch of code clean ups.
https://fedorahosted.org/releases/i/p/iptraf-ng/iptraf-ng-1.1.4.tar.gz
https://fedorahosted.org/releases/i/p/iptraf-ng/iptraf-ng-1.1.4.tar.gz.sum
Jan Engelhardt (1):
build: prefer ncurses6 and wide
Nikola Pajkovsky (29):
token-ring: kernel v3.5 kill off token-ring support
build: add rule for create gtags
build: clean warnings
capture: introduce packet capturing
build: fix wrongly define built-in header
detstat: neg one if() and linerize code
hostmon: neg one if() and linerize code
pktsize: neg one if() and linerize code
ethhdr: add new member into pkt_hdr struct
fddihdr: add new member into pkt_hdr struct
packet: pkt_cast_hdrp can take an offset to pkt_buf
iphdr, ip6_hdr: add new members into pkt_hdr struct
detstat: remove superfluous framelen variable
packet: introduce pkt_ipv4_len()
packet: introduce pkt_ip_protocol()
packet: introduce pkt_iph_len()
promics: full rewrite
instances: knock out instaneces.*
locking: only one instance of iptraf can be run
Revert "locking: only one instance of iptraf can be run"
Revert "instances: knock out instaneces.*"
Revert "promics: full rewrite"
promisc: full rewrite
instances: knock out instances.[ch]
locking: only one instance of iptraf can be run
tcptable.h: make max() macro strict type-checking
Merge branch 'master' of git://git.inai.de/iptraf
comat defines to 802.1ad / 802.1ah / QinQ ethertypes
iptraf-ng 1.1.4
Ricardo Catalinas Jiménez (1):
Remove the mention of `less' from INSTALL
Vitezslav Samel (64):
iptraf.c: remove unused code
fltmgr.h: remove unneded IGNORE_FILTER_PROTOTYPES #ifdef
rename local variable exitloop in tui/*.c to endloop
sanitize extern variables
removeaport(): fix segfault when there are no ports to remove
remove circular dependency between serv.h and options.h
remove unused #ifndef conditionals
use integer constant when dealing with integer variables
packet.h: decrease packet capture length to 96 bytes
remove ISDN interfaces support
serv.c: updateportent(): count packets even if dport is the same as sport
serv.c: writeutslog(): fix the printed rate in non-KBITS mode
serv.c: use struct proto_counter to count packets and bytes
serv.c: use struct rate to compute traffic flow rate
hostmon.c: remove unused variables
hostmon.c: use struct rate to print traffic rates
iptraf.c: main(): fix command line checks
rename rate_init() to rate_alloc()
split up rate_alloc() into rate_alloc() and rate_init()
ipmon(): use struct rate to print TCP flow rate
remove now unused bar.c and bar.h
packet.c: do not poll() for key press when not needed
usage.c: fix spelling (*_buildin() --> *_builtin())
define __attribute__((format(printf, x, y))) as __printf(x,y)
capture-pkt.c: fflush() stdout only
packet.h: pkt_iph_len(): make it function rather than macro
use pkt_ip_protocol() in place of ip6_hdr->ip6_nxt
use pkt_ip_protocol() in place of iphdr->protocol
rvnamed.c: name_resolved(): rewrote to fix the IPv6 case
rvnamed.c: don't use magic numbers
rvnamed.c: addrstat(): rewrite to work with IPv6 addresses
revname.c: use inet_ntop() instead of deprecated inet_ntoa()
revname.c: include revname.h to pull in declarations
revname(): explicitly pass size of target space
use inet_ntop() instead of deprecated inet_ntoa() (take 2)
sockaddr.c: new helpers ...
use sockaddr_*() helpers for addresses
use port inside struct sockaddr_(sin,sin6) instead of explicitly defined one
merge the same statements in the if() {} else {} clauses
centralize layer 3 packet handling
add 802.1ad and QinQ VLAN handling
make struct OPTIONS options global
kill unfinished work on graphing logging
fix: show program interface only if not given any command line arg
fix: clear screen before exit when given arg on cmdline
make struct filterstate ofilter global
don't pass ofilter variable to functions when not needed
screen_update_needed(): merge the same code into the function
push ntohs(port) down to the point we're getting it from packet
change port-like variables to type in_port_t
sockaddr_ntop(): kill warning on printf argument
tcplog_flowrate_msg(): cleanup and fix
ipfilter(): simplify the code using new port_in_range() function
ipfilter(): simplify the code using new addr_in_net() function
ifstats(): optimization
servmon(): optimization
packet_size_breakdown(): optimization
ifstats.c: print_if_entries(): start at first visible entry
ifstats(): simplify scrolling
packet.h: change spaces in indentation to tabs
packet.h: remove unused open_socket() declaration
packet_get(): receive packets using recvmsg() instead of recvfrom()
iptraf.c: fix displaying long interface names
ifstats.c: update all rates not only the visible ones
--
Nikola
10 years, 2 months