Hi, Fresh install of F26. First user created in the installation process, no issue. 2nd user created with kuser from 1st user session. This second user cannot log in from sddm but he can log in from a terminal and run startx which works fine.
Apparently, everytime he tries to login from sddm, we get this in dmesg: [ 8867.558759] sddm-helper[6948]: segfault at 0 ip 00007f141e369b1e sp 00007ffca5cf19f0 error 4 in libc-2.25.so[7f141e2f7000+1c7000]
Frédéric
On Tue, 2017-10-03 at 09:03 +0200, Frédéric Bron wrote:
Hi, Fresh install of F26. First user created in the installation process, no issue. 2nd user created with kuser from 1st user session. This second user cannot log in from sddm but he can log in from a terminal and run startx which works fine.
Apparently, everytime he tries to login from sddm, we get this in dmesg: [ 8867.558759] sddm-helper[6948]: segfault at 0 ip 00007f141e369b1e sp 00007ffca5cf19f0 error 4 in libc-2.25.so[7f141e2f7000+1c7000]
Please don't cross-post to multiple lists. There are reasons why this is against the guidelines.
poc
First user created in the installation process, no issue. 2nd user created with kuser from 1st user session. This second user cannot log in from sddm but he can log in from a terminal and run startx which works fine.
Apparently, everytime he tries to login from sddm, we get this in dmesg: [ 8867.558759] sddm-helper[6948]: segfault at 0 ip 00007f141e369b1e sp 00007ffca5cf19f0 error 4 in libc-2.25.so[7f141e2f7000+1c7000]
Hi, nobody has this problem? It's very painful not to be able to log in! Frédéric
On 10/06/17 13:14, Frédéric Bron wrote:
First user created in the installation process, no issue. 2nd user created with kuser from 1st user session. This second user cannot log in from sddm but he can log in from a terminal and run startx which works fine.
Apparently, everytime he tries to login from sddm, we get this in dmesg: [ 8867.558759] sddm-helper[6948]: segfault at 0 ip 00007f141e369b1e sp 00007ffca5cf19f0 error 4 in libc-2.25.so[7f141e2f7000+1c7000]
Hi, nobody has this problem? It's very painful not to be able to log in!
I don't normally use kuser. So, I just tried it and verified your issue.
The problem is that the user's home directory is being created with the wrong selinux context. Just do a "restorecon -R /home/whatever" and it will be just fine.
You can see the wrong context by... "ls -Zd /home/whatever".
That works, thanks! I will report the bug. Frédéric
2017-10-06 7:38 GMT+02:00 Ed Greshko ed.greshko@greshko.com:
On 10/06/17 13:14, Frédéric Bron wrote:
First user created in the installation process, no issue. 2nd user created with kuser from 1st user session. This second user cannot log in from sddm but he can log in from a terminal and run startx which works fine.
Apparently, everytime he tries to login from sddm, we get this in dmesg: [ 8867.558759] sddm-helper[6948]: segfault at 0 ip 00007f141e369b1e sp 00007ffca5cf19f0 error 4 in libc-2.25.so[7f141e2f7000+1c7000]
Hi, nobody has this problem? It's very painful not to be able to log in!
I don't normally use kuser. So, I just tried it and verified your issue.
The problem is that the user's home directory is being created with the wrong selinux context. Just do a "restorecon -R /home/whatever" and it will be just fine.
You can see the wrong context by... "ls -Zd /home/whatever".
-- Fedora Users List - The place to go to speculate endlessly
kde mailing list -- kde@lists.fedoraproject.org To unsubscribe send an email to kde-leave@lists.fedoraproject.org
The problem is that the user's home directory is being created with the wrong selinux context. Just do a "restorecon -R /home/whatever" and it will be just fine.
For reference, here is the bugzilla bug: https://bugzilla.redhat.com/show_bug.cgi?id=1499125
Thanks for your help,
Frédéric