On Tue, Sep 10, 2013 at 11:13:00AM +0800, Baoquan He wrote:
On 08/30/13 at 01:20pm, Vivek Goyal wrote:
> On Thu, Aug 22, 2013 at 09:06:32AM +0800, Baoquan He wrote:
> > Hi Wade,
> > Thanks for your patch. I know high priority tasks need be handled
> > firstly.
> > Don't be discouraged. I will merge it with tiny adjusting.
> This path define strip_xyz() 2 times in two separate files. I think it
> is high time we start thinking of intorducing a shared functions file
> for kdump which various kdump scripts can share.
> Adding duplicate code is bad.
> Chao, you were planning to look into this. Did you make any progress?
Since Chao has taken the task to introducing a shared functions file for
kdump file, I would like to merge this patch directly. Or if you think
it's not good, I can wait until Chao's patch for shared functions file
We have let it go multiple times. I don't like the idea of duplicating
functions any more.
So somebody please create a common functions file and put strip_xyz()
in that. Let us not create common instance of that function twice.