I was going through some recipes earlier today and came up with this
thought: What if we renamed the <machines> section to <network>?
It's almost too late for that, but using network instead of machines
could make much more sense in the future when we plan to extend the pool
of supported entities from machines also to switches, possibly routers
and other devices.
This way, we would always have to add a new section like
But in case it would be called <network> we would just add new child
element. It would be also much more readable that way -- you have a
network of nodes that are connected through their interfaces and you
have tasks for that network.
I know that names don't matter that much in the long run, but (imho)
they matter a lot when you try to explain these concepts to newcommers
(which is probably what we would like to do after the release).
What do you guys think about this? :-)