On 29/08/2019 20:01, Ben Rosser wrote:
> Hm, does it make sense then to have a compatibility package for lodash3?
I think we may have to multiversion it yes. Been thinking that for
I'll try and have a look at doing a lodash4 version of the spec
over the weekend...
> dnf repoquery --whatrequires nodejs-lodash says:
You need to look at all the nodejs-lodash-xxx modules as well which
are built from the same source, although they don't make as much
difference as I expected. That and BRs which I haven't looked at.
> My guess is also that at least *some* of these packages have a newer
> release which support lodash 4 but no one has updated the package,
> whether because the package is effectively unmaintained or the
> maintainer is overworked or worried about breaking dependencies. :(
Oh probably quite a lot do, it's been a bit chicken and egg having
to try and do everything at once, or even audit what is actually
doable - ie what dependants have a new version with support.
> For instance, looking at the last package on this list... the current
> version of zip-stream is 2.1.2 and does not actually require lodash at
> all anymore.
Somebody should update it then ;-)
Tom Hughes (tom(a)compton.nu)
(My bad, I didn't notice I had to manually reply all on this list. Apologies)
On Thu, Aug 29, 2019 at 2:44 PM Tom Hughes <tom(a)compton.nu> wrote:
> On 29/08/2019 14:37, Ben Rosser wrote:
> > I can work on this and submit pull requests to the packages in
> > question, if that would be helpful, but I wanted to check in here
> > before doing so. As best as I can tell, the packages in question that
> > need updating are:
> > * nodejs-grunt
> > * nodejs-grunt-legacy-log
> > * nodejs-grunt-legacy-log-util
> Both legacy-log and legacy-log-util are mine and the reason
> that I haven't updated them is that the 2.x versions require
> lodash 4.x and we don't have that and getting to it is a major
> project because 3.x and 4.x are totally incompatible and lots
> of things use it. Plus lodash has a crazy system that packages
> the same code is lots of different variants.
> Tom Hughes (tom(a)compton.nu)
Hm, does it make sense then to have a compatibility package for lodash3?
dnf repoquery --whatrequires nodejs-lodash says:
I own discord-irc, and I happen to know it actually wants lodash 4 but
seems to (mostly) work with the version of lodash is in Fedora 30--
I'm running an instance of it currently on a F30 machine. See
upstream's package.json here:
My guess is also that at least *some* of these packages have a newer
release which support lodash 4 but no one has updated the package,
whether because the package is effectively unmaintained or the
maintainer is overworked or worried about breaking dependencies. :(
For instance, looking at the last package on this list... the current
version of zip-stream is 2.1.2 and does not actually require lodash at
Over the last few days, I took over some pieces of nodejs-grunt that
had been retired due to being FTBFS in F31/Rawhide:
* nodejs-dateformat (not part of grunt, but a dependency)
Without grunt-legacy-util, as far as I can tell, nodejs-grunt was
unusable-- a package I had that used grunt for its unit tests could
not be built because grunt could not be installed. So things were
unfortunately pretty broken here.
I've updated all four packages to their latest upstream releases and
rebuilt them successfully. However, the-- outdated-- version of grunt
we are shipping explicitly requires grunt-legacy-util >= 1.0 && < 1.1.
grunt-legacy-util in Rawhide is now version 1.1, so to finish this we
either need to update the rest of grunt (or use %nodejs_fixdep and
hope for the best, I suppose).
I can work on this and submit pull requests to the packages in
question, if that would be helpful, but I wanted to check in here
before doing so. As best as I can tell, the packages in question that
need updating are: