Please read the draft :
http://fedoraproject.org/wiki/PackagingDrafts/PHP
* Requires and Provides
* Macros and scriptlets
And give feedback before this being proposed to FPC.
Comments on "channels" are also welcome ;)
Remi.
Hi,
What I was thinking (in an quite old discussion) is now reality
According to PHP Guidelines, pear extension must be named
php-pear-<extension>.
That's ok for standard pear.php.net channel.
With not standard channel we can encounter conflicts.
llaumgui is working on submitting ezComponents for review.
http://ezcomponents.org/
For example, one of the extension is Mail and php-pear-Mail already exists.
My proposal is :
1/ Channel package : php-channel-<channelalias>
Virtual provides :
php-channel(<channelname>)
php-channel(<channelalias>)
Ok for existing channels (phpunit, phping, ...) already in Fedora repository
2/ Extension package : php-<channelalias>-<extension>
Virtual provides :
php-pear([ <channelname>/ ] <extension>)
So, for standard channel :
php-pear-<extension>
So we can use :
Standard Channel:
php-pear-Mail providing php-pear(Mail) = 1.1.14
Non standard Channel:
php-ezc-Mail providing php-pear(components.ez.no/Mail) = 1.6
That means that a few packages "should" to be renamed, p.e.
php-pear-PHPUnit => php-phpunit-PHPUnit
(which is not really required still no conflicts exists)
This packages already use the right virtual provides
I will try to write this ASAP (for FPC/FESco approval) in
http://fedoraproject.org/wiki/PackagingDrafts/PHP
Comments ?
Remi.
P.S. another solution for ezcomponents is to build php-ezcomponents from
global tarball without using the pear mecanism (but I really dislike
this solution)