-----BEGIN PGP SIGNED MESSAGE----- Hash: SHA1
Tim Jackson a écrit :
I've been meaning to say it for a while, but if anyone wants to try the latest (CVS) version of PEAR_Command_Packaging, I did add support for both:
Well, I'm working on this.
Make first SRPM available :
http://rpms.famillecollet.com/SRPMS/php-pear-PEAR-Command-Packaging-0.1.3-0....
What I've done : - - update the fedora specific patch (don't know if all is needed) - - update the fedora template.spec - - add the fedora template-channel.spec
In both, I change the name of the .xml to %{name} (we could encounter conflict if we only use %{pear_name}). %{name} seems a robust solution.
I cannot change the default for doc_files_relocation_script and doc_files_statement...
Channel generated spec seems ok.
There is an issue in the generated extension spec in the uninstall command.
In template : @possible_channel@%{pear_name} Generated : components.ez.no%{pear_name}
We need a / between channel and extension name.
All seems ok with the PHP Guideline draft Update https://fedoraproject.org/wiki/PackagingDrafts/PHP
Remi, Regards.