I know in my case the trick was the partd mklabel command; once I did "partd  /dev/hda mklabel" and then specify "mac" I was able to let FC4 do the default partitioning and it worked.


Hugh Caley | Unix Systems Administrator | CIS
AFFYMETRIX INC. | 6550 Vallejo St. Ste 100 | Emeryville, CA 94608
Tel: 510-428-8537 | Hugh_Caley@affymetrix.com

-----Original Message-----
From: fedora-ppc-bounces@lists.infradead.org on behalf of listman
Sent: Thu 7/21/2005 11:00 PM
To: fedora-ppc@lists.infradead.org
Subject: More Partition woes

Mac mini 1.42 w/ 512MB ram
Fedora Core 4 PPC
installing with
linux video=ofonly resolution=1024x768
The following error was from my last install using the whole drive.

I used pdisk this time and got rid of the msdos partitoins I created
with fdisk (at least I think thats what I read somewhere in the
I deleted all the partitions except the apple bootstrap - only because
it wouldn't let me (ya I know that probably wouldn't be a good idea if
it did right - bull in a china shop)

Here's is a snippet of my errors during boot
PCI: Cannot allocate resource region 0 of device 0001:10:18.0
PCI: Cannot allocate resource region 0 of device (oops missed that one
sorry - did a copy and paste - forgot to update)
radeonfb (0000:00:10:0):invalid ROM signature 0 should be be0xaa55
macserial: cant request IO resource !
Red Hat nash version ###
EXT3-fs: unable to read superblock
mount: error 22 mounting ext3
2 more lines then kernel panic
I may have missed a few lines, I apologize but I'm impatient and its
getting late - I want to get this thing going :-)

I booted into rescue mode and could not mount /dev/hda3 even when I
supplied the type - sooo
I'm going to start over with a fresh install of osx, splitt the drive
and select free space for the second partition.
then right after anaconda starts I'm going into tty2 and naming the
unamed partitions using parted. After that should I partition the drive
myself or let fedora partition it. I've tried so many different
variables I know I'm missing something very simple.
first time openfirmware couldn't see the bootstrap second time (ok maybe
it was the sixth or seventh but who's counting) I couldn't mount the
root partition even in rescue mode.
anyone have any last pointers.
If there are any rtfm post coming my way I'm heading there now (again)
while OSX is installing.
Thanks for all the help

Tired of me yet - don't worry you will be.

Fedora-ppc mailing list