I've noticed that we started to use the word 'check' for naming the scripts
performing package-level or system-level checks/tests. I'd like to be consistent in
our code and in our documentation, so that our users are not confused. Can somebody
(probably Tim) clarify what should we call a 'check' and what should we call a
'test'? Do I understand correctly that 'checks' are anything provided by
the users (the scripts), and 'tests/testing' will be used mainly for denoting
At the moment, I'm working on porting autoqa.test.TestDetail class into Taskotron.
When following these directions, I guess it should be called