On 04/06/10 18:40, David Malcolm wrote:
On Fri, 2010-06-04 at 18:00 +0100, Robin Bowes wrote:
> I just tried to rebuild ruby-18.104.22.1688-16.el5.fr191.src.rpm on CentOS
> 5.5 and get this error:
> + autoconf
> configure.in:4: error: Autoconf version 2.60 or higher is required
> configure.in:4: the top level
> autom4te: /usr/bin/m4 failed with exit status: 63
> error: Bad exit status from /var/tmp/rpm-tmp.92052 (%build)
> Note that this is the el5 package.
> Can that requirement be relaxed, ie. will it work with autoconf-2.59-12
> that is available on RHEL/CentOS 5.5 ?
I don't know if Ruby needs it, but I ran into a similar issue for Python
2.6 in EPEL 5: the configure.in required autoconf 2.61.
To get around this, I set up the python26.spec file to make it easy to
regenerate this file on a Fedora box with a more recent autoconf.
grep for "regenerate_autotooling_patch" in here:
which also has links to docs on getting the newer autoconf.
Thanks, but... ugh!