Hi,
with my previous rootDSE patch I introduced a new core dump issue,
because srv_opts wasn't initialised if the rootDSE was missing. This
patch should fix it.
bye,
Sumit
-----BEGIN PGP SIGNED MESSAGE-----
Hash: SHA1
The attached patch reverts the change I introduced earlier with my patch
c825253e74027f87b900c0b811ae019d767c0848.
The patch is a one-liner but its context is a little more complex - I
actually reached out to Martin Nagy, who wrote much of the original fail
over code to be sure.
The fail over code is not strictly in charge of resolving. Its main
function is to provide a server to connect to for a service.
It is legal, although not currently used, to have a server that has no
name (server->common == NULL). In this case, no resolving should be done
and it is assumed that the failover user, which are the SSSD back ends
in our case, would perform any resolving out of band, perhaps using the
user_data attribute of fo_server structure.
The attached patch would fix the segfault described in #692472 but not
its root cause, which appears to be an issue with the confdb.
Jakub
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.4.11 (GNU/Linux)
Comment: Using GnuPG with Fedora - http://enigmail.mozdev.org/
iEYEARECAAYFAk2Vut0ACgkQHsardTLnvCXhEACfVTn5Cf8UNxfZVXjH8aLFDM0g
NB0AnRjyOoj1hJLoRYMgInB4tw3enw4/
=Jf9X
-----END PGP SIGNATURE-----
Hi,
I'd like to start working on following ticket:
https://fedorahosted.org/sssd/ticket/808
Please take a look at the ticket and if you can think of any other attributes
which might use case-insensitive search, add a comment to the ticket.
Thank you very much
Jan