https://fedorahosted.org/sssd/ticket/1772
Changes done: - definitions of safealign macros have been removed from src/sss_client/sss_cli.h and src/util/util.h and put into new header (the old headers include this new header). This change was done to avoid code duplication.
- Macros that copy bytes from a variable to byte buffer have been renamed from SAFEALIGN_SET_<type> to SAFEALIGN_VAR2BUF_<type>.
- Macros that copy bytes from a byte buffer to a variable have been renamed from SAFEALIGN_COPY_<type> to SAFEALIGN_BUF2VAR_<type>
- Aliases have been added to allow the old names to be used in the code (we can remove the aliases when the old names are replaced with the new ones on all places in the code, but for now, it is good to allow both alternatives, so that this patch can be smaller)
Thanks Michal