Hello,
please see attached patch which is result of discussion in thread:
LDAP: tokengroups do not work with id_provider=ldap
[snip]
>> Anyhow, find_subdomain_by_sid is misnamed, we routinely use the function >> to find the primary domain. > I think find_subdomain_by_sid() does what the name says and of course it > can return the primary domain as long as the SID of the domain is know
^^^^^^ fwiw, this was my concern, the function is named "find_subdomain" yet it can find both main domain and subdomain. But I won't bikeshed any further.
ah, sorry, now I see your point. I agree that the name misleading but I think this can be fixed after the release.
Would 's/find_subdomain_by_sid/find_domain_by_sid/' be a sufficient solution?
Thanks,
Pavel Reichl
On Fri, Jul 18, 2014 at 05:47:05PM +0200, Pavel Reichl wrote:
Hello,
please see attached patch which is result of discussion in thread:
LDAP: tokengroups do not work with id_provider=ldap
[snip]
>>>Anyhow, find_subdomain_by_sid is misnamed, we routinely use the function >>>to find the primary domain. >>I think find_subdomain_by_sid() does what the name says and of course it >>can return the primary domain as long as the SID of the domain is know ^^^^^^ fwiw, this was my concern, the function is named "find_subdomain" yet it can find both main domain and subdomain. But I won't bikeshed any further.
ah, sorry, now I see your point. I agree that the name misleading but I think this can be fixed after the release.
Would 's/find_subdomain_by_sid/find_domain_by_sid/' be a sufficient solution?
Thanks,
Pavel Reichl
Compiles and find_subdomain_by_id is nowhere to be found: $ git grep find_subdomain_by_sid $ echo $? 1
Patch looks OK, too.
ACK
On 07/20/2014 10:06 PM, Jakub Hrozek wrote:
On Sun, Jul 20, 2014 at 09:49:46PM +0200, Jakub Hrozek wrote:
ACK
I take the ack back :-)
Can you rebase on top of the tokengroups fix patches?
Sure, and I also added patch for renaming find_subdomain_by_name as I think same reasons for renaming find_subdomain_by_sid applies to it.
sssd-devel mailing list sssd-devel@lists.fedorahosted.org https://lists.fedorahosted.org/mailman/listinfo/sssd-devel
On Mon, Jul 21, 2014 at 09:30:06AM +0200, Pavel Reichl wrote:
On 07/20/2014 10:06 PM, Jakub Hrozek wrote:
On Sun, Jul 20, 2014 at 09:49:46PM +0200, Jakub Hrozek wrote:
ACK
I take the ack back :-)
Can you rebase on top of the tokengroups fix patches?
Sure, and I also added patch for renaming find_subdomain_by_name as I think same reasons for renaming find_subdomain_by_sid applies to it.
There is one more to convert -- find_subdomain_by_object_name()
On 07/21/2014 12:03 PM, Jakub Hrozek wrote:
On Mon, Jul 21, 2014 at 09:30:06AM +0200, Pavel Reichl wrote:
On 07/20/2014 10:06 PM, Jakub Hrozek wrote:
On Sun, Jul 20, 2014 at 09:49:46PM +0200, Jakub Hrozek wrote:
ACK
I take the ack back :-)
Can you rebase on top of the tokengroups fix patches?
Sure, and I also added patch for renaming find_subdomain_by_name as I think same reasons for renaming find_subdomain_by_sid applies to it.
There is one more to convert -- find_subdomain_by_object_name() _______________________________________________ sssd-devel mailing list sssd-devel@lists.fedorahosted.org https://lists.fedorahosted.org/mailman/listinfo/sssd-devel
OK, I added new patch and amended some indentation in prev two.
Thanks!
On Mon, Jul 21, 2014 at 02:23:57PM +0200, Pavel Reichl wrote:
On 07/21/2014 12:03 PM, Jakub Hrozek wrote:
On Mon, Jul 21, 2014 at 09:30:06AM +0200, Pavel Reichl wrote:
On 07/20/2014 10:06 PM, Jakub Hrozek wrote:
On Sun, Jul 20, 2014 at 09:49:46PM +0200, Jakub Hrozek wrote:
ACK
I take the ack back :-)
Can you rebase on top of the tokengroups fix patches?
Sure, and I also added patch for renaming find_subdomain_by_name as I think same reasons for renaming find_subdomain_by_sid applies to it.
There is one more to convert -- find_subdomain_by_object_name() _______________________________________________ sssd-devel mailing list sssd-devel@lists.fedorahosted.org https://lists.fedorahosted.org/mailman/listinfo/sssd-devel
OK, I added new patch and amended some indentation in prev two.
Thanks!
Thanks, I grepped the headers for similar function names and I think we're good now.
ACK
On Tue, Jul 22, 2014 at 09:39:46AM +0200, Jakub Hrozek wrote:
On Mon, Jul 21, 2014 at 02:23:57PM +0200, Pavel Reichl wrote:
On 07/21/2014 12:03 PM, Jakub Hrozek wrote:
On Mon, Jul 21, 2014 at 09:30:06AM +0200, Pavel Reichl wrote:
On 07/20/2014 10:06 PM, Jakub Hrozek wrote:
On Sun, Jul 20, 2014 at 09:49:46PM +0200, Jakub Hrozek wrote:
ACK
I take the ack back :-)
Can you rebase on top of the tokengroups fix patches?
Sure, and I also added patch for renaming find_subdomain_by_name as I think same reasons for renaming find_subdomain_by_sid applies to it.
There is one more to convert -- find_subdomain_by_object_name() _______________________________________________ sssd-devel mailing list sssd-devel@lists.fedorahosted.org https://lists.fedorahosted.org/mailman/listinfo/sssd-devel
OK, I added new patch and amended some indentation in prev two.
Thanks!
Thanks, I grepped the headers for similar function names and I think we're good now.
ACK
Pushed to master: b011330c77168cdd864aaae54a75214935136c05 db18dda869bc6c52a41797b2066cf121cf10f49c 9ca0071db0e226e4e65b2a80fdeddd5048ca8990
sssd-devel@lists.fedorahosted.org