Change in vdsm[master]: Fix "unknown device" issue for balloon device
by wudxw@linux.vnet.ibm.com
Mark Wu has uploaded a new change for review.
Change subject: Fix "unknown device" issue for balloon device
......................................................................
Fix "unknown device" issue for balloon device
The balloon device's 'alias' property should be updated in function
_getUnderlyingBalloonDeviceInfo(), otherwise it will be recognized as a
unknown device in _getUnderlyingUnknownDeviceInfo().
For the 'model' property, it must be included in the balloon device
parameter and libvirt will not change it, so we needn't get back from
libvirt.
For the 'address' property, libvirt may change it on confict addresses.
So change to always update 'address' from libvirt as the way we handle
drives and network interfaces.
Change-Id: Ibb9c371d1f3d90521cc4bfb9516a0bb979843f52
Signed-off-by: Mark Wu <wudxw(a)linux.vnet.ibm.com>
---
M vdsm/libvirtvm.py
1 file changed, 6 insertions(+), 7 deletions(-)
git pull ssh://gerrit.ovirt.org:29418/vdsm refs/changes/01/3901/1
--
To view, visit http://gerrit.ovirt.org/3901
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: newchange
Gerrit-Change-Id: Ibb9c371d1f3d90521cc4bfb9516a0bb979843f52
Gerrit-PatchSet: 1
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Mark Wu <wudxw(a)linux.vnet.ibm.com>
11 years, 4 months
Change in vdsm[master]: Introduce a singleton decorator
by wudxw@linux.vnet.ibm.com
Mark Wu has uploaded a new change for review.
Change subject: Introduce a singleton decorator
......................................................................
Introduce a singleton decorator
When I try to change clientIF into singleton, I found it would introduce
duplicate code which was used in supervdsm.py and resourceManager.py.
So this patch adds a generic singleton decorator for reuse. If this one
looks good, I will change SuperVdsmProxy and ResourceManager to use this
decrator.
Change-Id: I17c1b7be60a50cdaa731ee88f29d2017ea6c3f2b
Signed-off-by: Mark Wu <wudxw(a)linux.vnet.ibm.com>
---
M tests/Makefile.am
A tests/utilsTests.py
M vdsm/utils.py
3 files changed, 49 insertions(+), 1 deletion(-)
git pull ssh://gerrit.ovirt.org:29418/vdsm refs/changes/39/4839/1
--
To view, visit http://gerrit.ovirt.org/4839
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: newchange
Gerrit-Change-Id: I17c1b7be60a50cdaa731ee88f29d2017ea6c3f2b
Gerrit-PatchSet: 1
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Mark Wu <wudxw(a)linux.vnet.ibm.com>
11 years, 4 months
Change in vdsm[master]: CpuPinning for vdsClient (#514657)
by lhornyak@redhat.com
Laszlo Hornyak has posted comments on this change.
Change subject: CpuPinning for vdsClient (#514657)
......................................................................
Patch Set 1: (2 inline comments)
....................................................
Commit Message
Line 5: CommitDate: 2012-06-04 17:23:53 +0200
Line 6:
Line 7: CpuPinning for vdsClient (#514657)
Line 8:
Line 9: https://bugzilla.redhat.com/514657
see previous patch
Line 10:
Line 11: Adds support for CpuPinning arguments in vdsClient.
Line 12: example:
Line 13: cpuPinning="{0:'1'}"
....................................................
File vdsm_cli/vdsClient.py
Line 1586: 'o keyboardLayout : language code of client keyboard',
Line 1587: 'o cpuType : emulated cpu (with optional flags)',
Line 1588: 'o emulatedMachine : passed as qemu\'s -M',
Line 1589: 'o devices={name:val[, name:val, name:{name:val, name:val}]} : add a fully specified device',
Line 1590: 'o cpuPinning={vcpuid:val} cpu pinning'
I can change it to something like foobar, but the F same thing got merged to upstream. So will I have to change it there as well?
Line 1591: )),
Line 1592: 'hotplugNic': ( serv.hotplugNic,
Line 1593: ('<vmId> <nicspec>',
Line 1594: 'Hotplug NIC to existing VM',
--
To view, visit http://gerrit.usersys.redhat.com/1312
To unsubscribe, visit http://gerrit.usersys.redhat.com/settings
Gerrit-MessageType: comment
Gerrit-Change-Id: Ia1cf4c55d23bda450cad1543ac4d622f2949e03d
Gerrit-PatchSet: 1
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Laszlo Hornyak <lhornyak(a)redhat.com>
Gerrit-Reviewer: Dan Kenigsberg <danken(a)redhat.com>
Gerrit-Reviewer: Igor Lvovsky <ilvovsky(a)redhat.com>
Gerrit-Reviewer: Laszlo Hornyak <lhornyak(a)redhat.com>
11 years, 4 months
Change in vdsm[master]: CpuPinning (#514657)
by lhornyak@redhat.com
Laszlo Hornyak has posted comments on this change.
Change subject: CpuPinning (#514657)
......................................................................
Patch Set 2: (1 inline comment)
....................................................
Commit Message
Line 5: CommitDate: 2012-06-04 17:20:06 +0200
Line 6:
Line 7: CpuPinning (#514657)
Line 8:
Line 9: https://bugzilla.redhat.com/514657
I do not have one, so I would remove it, but Dan told me to add a BZ ID and this is the feature BZ.
Dan, please discuss with Igor!
Line 10:
Line 11: Adds support code to the "Vm.create()" (in backendcreateDomain) functionality in the
Line 12: method _DomXML.appendCpu. This code will create a <cputune> tag and
Line 13: append fill with <vcpupin> tags.
--
To view, visit http://gerrit.usersys.redhat.com/1311
To unsubscribe, visit http://gerrit.usersys.redhat.com/settings
Gerrit-MessageType: comment
Gerrit-Change-Id: Ia7016848d365d0e59454372461d66d167b100e7e
Gerrit-PatchSet: 2
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Laszlo Hornyak <lhornyak(a)redhat.com>
Gerrit-Reviewer: Dan Kenigsberg <danken(a)redhat.com>
Gerrit-Reviewer: Igor Lvovsky <ilvovsky(a)redhat.com>
Gerrit-Reviewer: Laszlo Hornyak <lhornyak(a)redhat.com>
11 years, 4 months
Change in vdsm[master]: PEP8 fixes for localFsSD
by Ryan Harper
Ryan Harper has uploaded a new change for review.
Change subject: PEP8 fixes for localFsSD
......................................................................
PEP8 fixes for localFsSD
% pep8 vdsm/storage/localFsSD.py
vdsm/storage/localFsSD.py:16:80: E501 line too long (80 characters)
vdsm/storage/localFsSD.py:49:80: E501 line too long (84 characters)
vdsm/storage/localFsSD.py:102:1: E302 expected 2 blank lines, found 1
Change-Id: I7ec53b45fc27b48d21638e405b219a66f2707b5b
Signed-off-by: Ryan Harper <ryanh(a)us.ibm.com>
---
M vdsm/storage/localFsSD.py
1 file changed, 4 insertions(+), 2 deletions(-)
git pull ssh://gerrit.ovirt.org:29418/vdsm refs/changes/38/3938/1
--
To view, visit http://gerrit.ovirt.org/3938
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: newchange
Gerrit-Change-Id: I7ec53b45fc27b48d21638e405b219a66f2707b5b
Gerrit-PatchSet: 1
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Ryan Harper <ryanh(a)us.ibm.com>
11 years, 4 months
Change in vdsm[master]: rest-api: Delete unneeded directory
by agl@us.ibm.com
Adam Litke has uploaded a new change for review.
Change subject: rest-api: Delete unneeded directory
......................................................................
rest-api: Delete unneeded directory
Hmm, I thought this orphaned directory had ben cleaned from the REST
infrastructure patch series. Let's squash it for good this time.
Signed-off-by: Adam Litke <agl(a)us.ibm.com>
Change-Id: I11ad4f8ae4219a75484334b9a772c7bfc44acb56
---
D tests/rest_override/__init__.py
1 file changed, 0 insertions(+), 0 deletions(-)
git pull ssh://gerrit.ovirt.org:29418/vdsm refs/changes/45/5045/1
--
To view, visit http://gerrit.ovirt.org/5045
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: newchange
Gerrit-Change-Id: I11ad4f8ae4219a75484334b9a772c7bfc44acb56
Gerrit-PatchSet: 1
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Adam Litke <agl(a)us.ibm.com>
11 years, 4 months
Change in vdsm[master]: CpuPinning for vdsClient (#514657)
by Igor Lvovsky
Igor Lvovsky has posted comments on this change.
Change subject: CpuPinning for vdsClient (#514657)
......................................................................
Patch Set 1: I would prefer that you didn't submit this
(2 inline comments)
....................................................
Commit Message
Line 5: CommitDate: 2012-06-04 17:23:53 +0200
Line 6:
Line 7: CpuPinning for vdsClient (#514657)
Line 8:
Line 9: https://bugzilla.redhat.com/514657
You can't use non-vdsm BZ# for vdsm patches. Please remove any appearance of it in commit message (or use real downstream vdsm BZ if you have one)
Line 10:
Line 11: Adds support for CpuPinning arguments in vdsClient.
Line 12: example:
Line 13: cpuPinning="{0:'1'}"
....................................................
File vdsm_cli/vdsClient.py
Line 1586: 'o keyboardLayout : language code of client keyboard',
Line 1587: 'o cpuType : emulated cpu (with optional flags)',
Line 1588: 'o emulatedMachine : passed as qemu\'s -M',
Line 1589: 'o devices={name:val[, name:val, name:{name:val, name:val}]} : add a fully specified device',
Line 1590: 'o cpuPinning={vcpuid:val} cpu pinning'
what is 'val'? real cpu? can you be more clear?
Line 1591: )),
Line 1592: 'hotplugNic': ( serv.hotplugNic,
Line 1593: ('<vmId> <nicspec>',
Line 1594: 'Hotplug NIC to existing VM',
--
To view, visit http://gerrit.usersys.redhat.com/1312
To unsubscribe, visit http://gerrit.usersys.redhat.com/settings
Gerrit-MessageType: comment
Gerrit-Change-Id: Ia1cf4c55d23bda450cad1543ac4d622f2949e03d
Gerrit-PatchSet: 1
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Laszlo Hornyak <lhornyak(a)redhat.com>
Gerrit-Reviewer: Dan Kenigsberg <danken(a)redhat.com>
Gerrit-Reviewer: Igor Lvovsky <ilvovsky(a)redhat.com>
11 years, 4 months
Change in vdsm[master]: CpuPinning (#514657)
by Igor Lvovsky
Igor Lvovsky has posted comments on this change.
Change subject: CpuPinning (#514657)
......................................................................
Patch Set 2: I would prefer that you didn't submit this
(1 inline comment)
just curious, what about migration?
....................................................
Commit Message
Line 5: CommitDate: 2012-06-04 17:20:06 +0200
Line 6:
Line 7: CpuPinning (#514657)
Line 8:
Line 9: https://bugzilla.redhat.com/514657
You can't use non-vdsm BZ# for vdsm patches.
Please remove any appearance of it in commit message
(or use real downstream vdsm BZ if you have one)
Line 10:
Line 11: Adds support code to the "Vm.create()" (in backendcreateDomain) functionality in the
Line 12: method _DomXML.appendCpu. This code will create a <cputune> tag and
Line 13: append fill with <vcpupin> tags.
--
To view, visit http://gerrit.usersys.redhat.com/1311
To unsubscribe, visit http://gerrit.usersys.redhat.com/settings
Gerrit-MessageType: comment
Gerrit-Change-Id: Ia7016848d365d0e59454372461d66d167b100e7e
Gerrit-PatchSet: 2
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Laszlo Hornyak <lhornyak(a)redhat.com>
Gerrit-Reviewer: Dan Kenigsberg <danken(a)redhat.com>
Gerrit-Reviewer: Igor Lvovsky <ilvovsky(a)redhat.com>
Gerrit-Reviewer: Laszlo Hornyak <lhornyak(a)redhat.com>
11 years, 4 months
Change in vdsm[master]: hook: balloon - Enable the virtio balloon
by agl@us.ibm.com
Adam Litke has uploaded a new change for review.
Change subject: hook: balloon - Enable the virtio balloon
......................................................................
hook: balloon - Enable the virtio balloon
Currently the virtio balloon is disabled for vdsm guests. Until we decide to
enable it by default, a hook is a convenient way to enable ballooning on a host.
This hook simply replaces the model attribute of the memballoon tag from none to
virtio.
Change-Id: Idc7d533268aff536179045db06b81e17c5fae3db
Signed-off-by: Adam Litke <agl(a)us.ibm.com>
---
M configure.ac
M vdsm.spec.in
M vdsm_hooks/Makefile.am
A vdsm_hooks/balloon/Makefile.am
A vdsm_hooks/balloon/before_vm_start.py
5 files changed, 63 insertions(+), 0 deletions(-)
git pull ssh://gerrit.ovirt.org:29418/vdsm refs/changes/16/4316/1
--
To view, visit http://gerrit.ovirt.org/4316
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: newchange
Gerrit-Change-Id: Idc7d533268aff536179045db06b81e17c5fae3db
Gerrit-PatchSet: 1
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Adam Litke <agl(a)us.ibm.com>
11 years, 4 months
Change in vdsm[master]: configuNetworks: no need to create set repeatedly
by Dan Kenigsberg
Dan Kenigsberg has uploaded a new change for review.
Change subject: configuNetworks: no need to create set repeatedly
......................................................................
configuNetworks: no need to create set repeatedly
Yes, this is a very minor performance improvement, but I still like it.
Change-Id: I6c182c877e5b1c0bc5e19797fae43a31940ba924
Signed-off-by: Dan Kenigsberg <danken(a)redhat.com>
---
M vdsm/configNetwork.py
1 file changed, 2 insertions(+), 2 deletions(-)
git pull ssh://gerrit.ovirt.org:29418/vdsm refs/changes/05/5005/1
--
To view, visit http://gerrit.ovirt.org/5005
To unsubscribe, visit http://gerrit.ovirt.org/settings
Gerrit-MessageType: newchange
Gerrit-Change-Id: I6c182c877e5b1c0bc5e19797fae43a31940ba924
Gerrit-PatchSet: 1
Gerrit-Project: vdsm
Gerrit-Branch: master
Gerrit-Owner: Dan Kenigsberg <danken(a)redhat.com>
11 years, 4 months