Hello Piotr Kliczewski, Timothy Asir, Dan Kenigsberg,
I'd like you to do a code review. Please visit
https://gerrit.ovirt.org/42308
to review the following change.
Change subject: gluster: rename glusterCreateBrick to glusterBrickCreate ......................................................................
gluster: rename glusterCreateBrick to glusterBrickCreate
To make consistency in function names in supervdsm and verb names in vdsm, this patch renames verb glusterCreateBrick to glusterBrickCreate
Change-Id: I367a864bc9bf4aa9b6a0d36b64f541fa89c61c0d Signed-off-by: Bala.FA barumuga@redhat.com --- M client/vdsClientGluster.py M vdsm/gluster/api.py M vdsm/gluster/apiwrapper.py M vdsm/gluster/storagedev.py M vdsm/rpc/vdsmapi-gluster-schema.json 5 files changed, 11 insertions(+), 11 deletions(-)
git pull ssh://gerrit.ovirt.org:29418/vdsm refs/changes/08/42308/1
diff --git a/client/vdsClientGluster.py b/client/vdsClientGluster.py index a4bce63..76b91e1 100644 --- a/client/vdsClientGluster.py +++ b/client/vdsClientGluster.py @@ -633,7 +633,7 @@ pp.pprint(status) return status['status']['code'], status['status']['message']
- def do_glusterCreateBrick(self, args): + def do_glusterBrickCreate(self, args): params = self._eqSplit(args) devList = params.get('devices', '').split(',') brickName = params.get('brickName', '') @@ -646,7 +646,7 @@ raidParams['stripeSize'] = int(params.get('stripeSize', 0)) raidParams['pdCount'] = int(params.get('pdCount', 0))
- status = self.s.glusterCreateBrick(brickName, mountPoint, + status = self.s.glusterBrickCreate(brickName, mountPoint, devList, fsType, raidParams) pp.pprint(status) return status['status']['code'], status['status']['message'] @@ -1172,8 +1172,8 @@ ('[volumeName=<volume_name>]', 'snapshot list for given volume' )), - 'glusterCreateBrick': ( - serv.do_glusterCreateBrick, + 'glusterBrickCreate': ( + serv.do_glusterBrickCreate, ('brickName=<brick_name> mountPoint=<mountPoint> ' 'devices=<device[,device, ...]> ' '[raidType=<raid_type>] [stripeSize=<stripe_size>] ' diff --git a/vdsm/gluster/api.py b/vdsm/gluster/api.py index 24b8230..918c3cc 100644 --- a/vdsm/gluster/api.py +++ b/vdsm/gluster/api.py @@ -672,9 +672,9 @@ return {'snapshotList': status}
@exportAsVerb - def createBrick(self, name, mountPoint, devList, fsType=None, + def brickCreate(self, name, mountPoint, devList, fsType=None, raidParams={}, options=None): - status = self.svdsmProxy.glusterCreateBrick(name, + status = self.svdsmProxy.glusterBrickCreate(name, mountPoint, devList, fsType, diff --git a/vdsm/gluster/apiwrapper.py b/vdsm/gluster/apiwrapper.py index 4768a86..f607dd4 100644 --- a/vdsm/gluster/apiwrapper.py +++ b/vdsm/gluster/apiwrapper.py @@ -81,9 +81,9 @@ def storageDevicesList(self, options=None): return self._gluster.storageDevicesList()
- def createBrick(self, name, mountPoint, devList, fsType=None, + def brickCreate(self, name, mountPoint, devList, fsType=None, raidParams={}): - return self._gluster.createBrick(name, mountPoint, + return self._gluster.brickCreate(name, mountPoint, devList, fsType, raidParams)
diff --git a/vdsm/gluster/storagedev.py b/vdsm/gluster/storagedev.py index 2aeabad..f4178e9 100644 --- a/vdsm/gluster/storagedev.py +++ b/vdsm/gluster/storagedev.py @@ -123,7 +123,7 @@
@makePublic -def createBrick(brickName, mountPoint, devNameList, fsType=DEFAULT_FS_TYPE, +def brickCreate(brickName, mountPoint, devNameList, fsType=DEFAULT_FS_TYPE, raidParams={}): def _getDeviceList(devNameList): return [blivetEnv.devicetree.getDeviceByName(devName.split("/")[-1]) diff --git a/vdsm/rpc/vdsmapi-gluster-schema.json b/vdsm/rpc/vdsmapi-gluster-schema.json index c86f43c..209bfbd 100644 --- a/vdsm/rpc/vdsmapi-gluster-schema.json +++ b/vdsm/rpc/vdsmapi-gluster-schema.json @@ -1274,7 +1274,7 @@ 'data': {'type': 'str', 'stripeSize': 'int', 'diskCnt': 'int'}}
## -# @GlusterHost.createBrick: +# @GlusterHost.brickCreate: # # Create a brick for the gluster volume # @@ -1293,7 +1293,7 @@ # # Since: 4.17.0 ## -{'command': {'class': 'GlusterHost', 'name': 'createBrick'}, +{'command': {'class': 'GlusterHost', 'name': 'brickCreate'}, 'data': {'name': 'str', 'mountPoint': 'str', 'devList': ['str'], '*fsType': 'str', '*raidParams': 'RaidDevice'}, 'returns': 'bool'}
automation@ovirt.org has posted comments on this change.
Change subject: gluster: rename glusterCreateBrick to glusterBrickCreate ......................................................................
Patch Set 1:
* Update tracker::IGNORE, no Bug-Url found * Check Bug-Url::WARN, no bug url found, make sure header matches 'Bug-Url: ' and is a valid url. * Check merged to previous::IGNORE, Not in stable branch (['ovirt-3.5', 'ovirt-3.4', 'ovirt-3.3'])
Piotr Kliczewski has posted comments on this change.
Change subject: gluster: rename glusterCreateBrick to glusterBrickCreate ......................................................................
Patch Set 1: Code-Review+1
Jenkins CI RO has abandoned this change.
Change subject: gluster: rename glusterCreateBrick to glusterBrickCreate ......................................................................
Abandoned
Abandoned due to no activity - please restore if still relevant
gerrit-hooks has posted comments on this change.
Change subject: gluster: rename glusterCreateBrick to glusterBrickCreate ......................................................................
Patch Set 1:
* Update tracker: IGNORE, no Bug-Url found
vdsm-patches@lists.fedorahosted.org