Hisao Taguchi may have found a great idea.  Hisao pointed to this article:



It describes a process to proactively load a different IDE driver to a Windows XP system before moving it to different hardware.   This absolutely parallels the problem I need to solve – and I gotta believe I am not alone.  I want to P2V a Windows 2003 Server with an uncooperative system disk driver.   I’ve tried virt-p2v, the old-fashioned ntbackup and restore, and an Acronis trial download.  So far, nothing works – and the whole challenge comes back to that virtio disk driver not being present in the source physical machine. 


If we could come up with a way to proactively install that virtio driver into a physical Windows Server host before P2Ving it, maybe we could solve P2V problems worldwide and it would be a huge step forward. 


-          Greg Scott



From: virt-bounces@lists.fedoraproject.org [mailto:virt-bounces@lists.fedoraproject.org] On Behalf Of Greg Scott
Sent: Monday, October 03, 2011 10:09 AM
To: virt@lists.fedoraproject.org
Subject: [fedora-virt] Restored Windows Server 2003 VM goes black


I tried a P2V migration last week and here might be a better spot to document the results.  I have an aging physical host running Windows 2003 Server and I want to P2V that host in to a libvirt VM.  The physical host uses a Compaq Smart Array 532 Controller with a Compaq Logical Volume SCSI disk device.  The logical volume is a RAID 5 set. 


I first tried using the new virt-p2v approach, but haven’t been successful.  So I tried doing it the old-fashioned way.  On a RHEL 6.1 host, I built a libvirt Windows 2003 VM from scratch using a virtio system drive.  Then, on the physical host, I ran ntbackup and backed up all the system drive files to a network share viewable from my newly provisioned VM.  I also backed up the system state.  From the 2003 VM, I restored the system drive files and system state and rebooted. 


When rebooting, the VM flashes a couple of POST SeaBIOS lines, then the console window goes black.  No BSOD, just black.  Virt-manager shows the VM is still powered on, but the console window just sits there, black, until I force the VM to power off.  I tried pressing F8 to see if I could get to a Windows boot menu, but this never worked.  I have a hunch something is going on with the new system virtual drive and the driver for the old system drive. 


I can boot the VM from a virtual CD and launch the Windows recovery console, and from there I can see the Windows installation.  The login uses the new password, so I think the ntbackup – restores did their jobs.  I tried a fixboot and fixmbr, but neither of these did any good.  I tried another ntbackup – restore, this time using an IDE system drive in my VM (the restore took 50 percent more time than with virtio), but this also made no difference. 


I ended up re-enabling the NIC on the physical host again and now I’m trying to come up with a plan C. Are there any other ideas I’m not thinking of?




-    Greg Scott