[389-users] Debian packaging and Ubuntu issues

Michele Baldessari michele at acksyn.org
Mon Oct 18 18:41:33 UTC 2010


Hi Roberto,

On Mon, Oct 18, 2010 at 12:15:44PM +0200, Roberto Polli wrote:
> The debian packages can't be straightforwardly installed on ubuntu due to 
> mismatching dependencies (matter of names, I think). 

could you send me the log of how it fails?

What's the Ubuntu distro you are using (maverick, natty, ?) and what
architecture? I just did a quick pbuilder run in a maverick and at least
building went fine.
If it turns out the only Dependencies need to be tweaked based on the
distribution that should be easily done [1]. If also Build-Dependencies
must be changed then a different branch for ubuntu would be needed in
the packaging VCS.

If I get around tweaking my scripts to autobuild and upload stuff
automatically, I'll just bite the bullet and create a repo for ubuntu.

regards,
Michele

[1] http://raphaelhertzog.com/2010/09/27/different-dependencies-between-debian-and-ubuntu-but-common-source-package/
-- 
Michele Baldessari <michele at acksyn.org> 
C2A5 9DA3 9961 4FFB E01B  D0BC DDD4 DCCB 7515 5C6D



More information about the 389-users mailing list