[389-users] Replication trouble when promoting dedicated Consumer to Multiple master

Reinhard Nappert rnappert at juniper.net
Thu Jul 14 14:25:10 UTC 2011


Do a   ldapsearch -b 'nsuniqueid=ffffffff-ffffffff-ffffffff-ffffffff,dc=mydomain,dc=com' -D <directory manager> -w <password> -s base objectclass=nstombstone

This gives you all the configured (history) of replication ids. The following is the output in my setup.

dn: nsuniqueid=ffffffff-ffffffff-ffffffff-ffffffff,o=base
objectClass: top
objectClass: nsTombstone
objectClass: extensibleobject
nsds50ruv: {replicageneration} 4df7a107000000010000
nsds50ruv: {replica 1 ldap://yale:389} 4df7a396000000010000 4e19ad950000000100
 00
nsds50ruv: {replica 3 ldap://norquay:389} 4df7a39d000000030000 4e1605650000000
 30000
nsds50ruv: {replica 4 ldap://mustrum:389} 4df7a3a0000000040000 4dfb93650000000
 40000
nsds50ruv: {replica 2 ldap://louise:389} 4df7a39a000000020000 4e171a0700000002
 0000
o: base
nsruvReplicaLastModified: {replica 1 ldap://yale:389} 00000000
nsruvReplicaLastModified: {replica 3 ldap://norquay:389} 00000000
nsruvReplicaLastModified: {replica 4 ldap://mustrum:389} 00000000
nsruvReplicaLastModified: {replica 2 ldap://louise:389} 00000000
                                                  /\
                                                   |
                                             replication-id

I am pretty sure you have somewhere there a duplicate of 3

-Reinhard


________________________________
From: 389-users-bounces at lists.fedoraproject.org [mailto:389-users-bounces at lists.fedoraproject.org] On Behalf Of Roland Schwingel
Sent: Thursday, July 14, 2011 7:39 AM
To: General discussion list for the 389 Directory server project.
Subject: Re: [389-users] Replication trouble when promoting dedicated Consumer to Multiple master

Hi Penedo...

Thanks for your reply....
Yes.. I did that already a couple of times. I am always coming to the  same error message...

Roland



From:        Penedo <penedo at gmail.com>
To:        "General discussion list for the 389 Directory server project." <389-users at lists.fedoraproject.org>
Date:        14.07.2011 13:08
Subject:        Re: [389-users] Replication trouble when promoting dedicated Consumer to Multiple master
Sent by:        389-users-bounces at lists.fedoraproject.org
________________________________



I'm far from being an expert but have you considered clearing the existing replication agreements and following the instructions for setting up multi-master from scratch?

On Jul 13, 2011 5:44 PM, "Roland Schwingel" <Roland.Schwingel at onevision.com<mailto:Roland.Schwingel at onevision.com>> wrote:
> Hi...
>
> Since yesterday I got some replication trouble.
>
> My Scenario
>
> server A < ----- server B <-----> server C
> -----> server D
> (dedicated Consumer) (multiple Master replica ID:1) (multiple
> Master replica ID:2) (Dedicated Consumer)
>
> The arrows are depicting the replication directions.
> In that scenario everything is fine.
>
> But I want to promote server D to a multiple Master replicating from/to
> server C.
>
> On server D I enabled changelog and changed the Replica Role of userRoot
> to Multiple Master (now with replica id 3)
> I created a replication aggrement to server C.
>
> When enabling that I see these error messages in error log on server D. At
> 08:51:53 I enabled the replication agreement from server D to server C:
>
> [13/Jul/2011:08:49:41 +0200] - 389-Directory/1.2.5 B2010.120.1414 starting
> up
> [13/Jul/2011:08:49:41 +0200] - slapd started. Listening on All Interfaces
> port 389 for LDAP requests
> [13/Jul/2011:08:49:41 +0200] - Listening on All Interfaces port 636 for
> LDAPS requests
> [13/Jul/2011:08:51:53 +0200] NSMMReplicationPlugin -
> repl_set_mtn_referrals: could not set referrals for replica
> dc=mydomain,dc=com: 32
> [13/Jul/2011:08:51:53 +0200] NSMMReplicationPlugin -
> multimaster_be_state_change: replica dc=mydomain,dc=com is going offline;
> disabling replication
> [13/Jul/2011:08:51:53 +0200] - WARNING: Import is running with
> nsslapd-db-private-import-mem on; No other process is allowed to access
> the database
> [13/Jul/2011:08:51:56 +0200] - import userRoot: Workers finished; cleaning
> up...
> [13/Jul/2011:08:51:57 +0200] - import userRoot: Workers cleaned up.
> [13/Jul/2011:08:51:57 +0200] - import userRoot: Indexing complete.
> Post-processing...
> [13/Jul/2011:08:51:57 +0200] - import userRoot: Flushing caches...
> [13/Jul/2011:08:51:57 +0200] - import userRoot: Closing files...
> [13/Jul/2011:08:51:59 +0200] - import userRoot: Import complete. Processed
> 772 entries in 5 seconds. (154.40 entries/sec)
> [13/Jul/2011:08:51:59 +0200] NSMMReplicationPlugin -
> multimaster_be_state_change: replica dc=mydomain,dc=com is coming online;
> enabling replication
> [13/Jul/2011:09:11:00 +0200] NSMMReplicationPlugin -
> agmt="cn=server-d_to_server-c" (server-c:389): Unable to aquire replica:
> the replica has the same Replica ID as this one. Replication is aborting.
> [13/Jul/2011:09:11:00 +0200] NSMMReplicationPlugin -
> agmt="cn=server-d_to_server-c" (server-c:389): Incremental update failed
> and requires administrator action
>
> It says that it has the same replica id, but this is not true. I assigned
> replica ID 3 to server-d and replica ID 2 to server-c
>
> from dse.ldif of server-d:
> dn: cn=replica,cn="dc=mydomain, dc=com",cn=mapping tree,cn=config
> objectClass: nsDS5Replica
> objectClass: top
> nsDS5ReplicaRoot: dc=mydomain, dc=com
> nsDS5ReplicaType: 3
> nsDS5Flags: 1
> nsds5ReplicaPurgeDelay: 604800
> nsDS5ReplicaBindDN: cn=replication manager,cn=config
> cn: replica
> creatorsName:
> uid=admin,ou=administrators,ou=topologymanagement,o=netscaperoot
> modifiersName:
> uid=admin,ou=administrators,ou=topologymanagement,o=netscaperoo
> t
> createTimestamp: 20110713065052Z
> modifyTimestamp: 20110713071007Z
> nsDS5ReplicaId: 3
> nsState:: //8AAExAHU4AAAAAAAAAAAEAAAA=
> nsDS5ReplicaName: 6c5f7682-1dd211b2-abcfd815-dc8d0000
> numSubordinates: 1
>
>
> from dse.ldif if server-c:
> dn: cn=replica,cn="dc=mydomain, dc=com",cn=mapping tree,cn=config
> objectClass: nsDS5Replica
> objectClass: top
> nsDS5ReplicaRoot: dc=mydomain, dc=com
> nsDS5ReplicaType: 3
> nsDS5Flags: 1
> nsDS5ReplicaId: 2
> nsds5ReplicaPurgeDelay: 604800
> nsDS5ReplicaBindDN: cn=replication manager,cn=config
> cn: replica
> creatorsName:
> uid=admin,ou=administrators,ou=topologymanagement,o=netscaperoot
> modifiersName: cn=Multimaster Replication Plugin,cn=plugins,cn=config
> createTimestamp: 20101105122639Z
> modifyTimestamp: 20110713073144Z
> nsState:: AgAAAMpJHU4AAAAAFgAAAAEAAAA=
> nsDS5ReplicaName: ee6ae602-1dd111b2-ae7bc446-6a0e0000
> numSubordinates: 2
>
> I already erased and recreated the server-d for a couple of times. Always
> with the same error.
> I created an empty instance of server-d set it to be a dedicated consumer.
> Created replication
> aggrement from server-c to server-d. Initiliazed consumer (server-d). On
> server-d I enabled
> than changelog and changed replication role to multiple master and
> assigned replica id 3.
> I when I create the replication aggreement from server-d to server-c I get
> this error.
>
> What am I doing wrong? I did the same thing a while ago for server-b and
> server-c and there
> it worked without trouble. (server-b was initially the single master in my
> net before
> the other servers appeared).
>
> Thanks for your help,
>
> Roland--
389 users mailing list
389-users at lists.fedoraproject.org
https://admin.fedoraproject.org/mailman/listinfo/389-users
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.fedoraproject.org/pipermail/389-users/attachments/20110714/38008914/attachment.html>


More information about the 389-users mailing list