[389-users] Centos 6?

夜神 岩男 supergiantpotato at yahoo.co.jp
Fri Jul 29 03:59:24 UTC 2011


On 07/29/2011 05:14 AM, Brett Dikeman wrote:
> Greetings,
>
> I'm trying to install 389 on Centos 6, following this:
>
> http://directory.fedoraproject.org/wiki/Install_Guide#New_Install
>
> The guide makes it out to be as simple as "configure EPEL, then
> execute yum install 389-ds".
>
> Instead, the install dies with yum not able to find a dozen or two
> dependencies, all of them perl, it looks like:
>
> -perl(Setup)
> -perl (Mozilla::LDAP::Utils)
> -perl(Resource)
>
> ...and so on (Dialog, DSMigration, Migration, DSUpdate etc.)
>
> I've tried both EPEL release, and EPEL testing.  I can't seem to find
> anyone else complaining about these issues, so I'm guessing I'm
> missing something.  Any suggestions?

Same thing happening here, on SL6 and CentOS6. So its not just you. 
Unfortunately I've had to switch to OpenLDAP for a bit until I can get 
this resolved (probably not for another month...). The weird thing is a 
lot of 389-ds packages are built and sitting in the EPEL repo, but 
389-ds-base isn't present and all that perl madness is just missing. I 
did find the lack of discussion a little odd -- seems like people would 
notice this missing.

If anyone knows a magical workaround that would permit a proper 389 
install it would be greatly appreciated (like "Geeze, get with it you 
knuckleheads, its been relabeled to the 390-ds now, duh.").

-Iwao



More information about the 389-users mailing list