[389-users] svn authentication

Dan Lavu dan at lavu.net
Thu Jun 20 19:43:09 UTC 2013


Try using AuthLDAPURL instead of AuthzLDAPURL and every other corresponding Authz parameter. I ran into this issue last week, a config file I knew worked a few years ago did not work now. Here is a sample of my working config;

   DAV svn
   SVNPath /var/www/svn/runlevelone

   SSLRequireSSL
   SSLVerifyClient optional
   SSLCACertificatePath /etc/openldap/certs/

   AuthLDAPURL "ldaps://ad03.runlevelone.lan/cn=users,dc=runlevelone,dc=lan?sAMAccountName?sub?(objectClass=*)"
   AuthLDAPBindDN "ldap at runlevelone.lan"
   AuthLDAPBindPassword "drinkanddrinkanddrinkandfight"

   AuthType Basic
   AuthName "Subveeeeeeersion"
   AuthBasicProvider ldap
   Require ldap-group cn=SVN Users,cn=users,dc=runlevelone,dc=lan
   #Require valid-user

 


On Jun 14, 2013, at 2:31 AM, Todor Petkov <zakk at online.bg> wrote:

> Can you try to set up a simple LDAP authentication for a directory? It does not have to be SVN, just a normal one (with some files in it).
> 
> Regards,
> 
> 
> --
> 389 users mailing list
> 389-users at lists.fedoraproject.org
> https://admin.fedoraproject.org/mailman/listinfo/389-users

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.fedoraproject.org/pipermail/389-users/attachments/20130620/57db076c/attachment.html>


More information about the 389-users mailing list