[389-users] Dirsrv-admin - dsgw issue with authentication

Zane Williamson zane at mochimedia.com
Fri Jun 21 21:08:14 UTC 2013


Just one old cookie from a few weeks back.  I made sure my browser will
accept all cookies from this domain.

The charset is not supported
(ISO_8859-1)

I am curious if this is causing issues.  I see this on pages displayed for
the dsgw.

The browser console output is telling me:

--
[14:05:53.182] A form was submitted in the windows-1252 encoding which
cannot encode all Unicode characters, so user input may get corrupted. To
avoid this problem, the page should be changed so that the form is
submitted in the UTF-8 encoding either by changing the encoding of the page
itself to UTF-8 or by specifying accept-charset=utf-8 on the form element.
@ https://mydomain.net/dsgwcmd/dosearch


On Fri, Jun 21, 2013 at 1:44 PM, Rich Megginson <rmeggins at redhat.com> wrote:

>  On 06/21/2013 02:35 PM, Zane Williamson wrote:
>
> Yes, I see
>
> -rw------- 1 dsadmin dsadmin  488 Jun 21 20:31 cookies.pb  It appears to
> be receiving cookie information and is updating fine.
>
>  The only [error] I am seeing is
>
>  "File does not exist: /usr/share/dirsrv/html/favicon.ico"
>
>  Is there perhaps an option in the dsgw conf where I can turn up the
> logging verbosity?
>
>
> not really
>
> Is there a cookie in your browser for dsgw?
>
>
>
> On Fri, Jun 21, 2013 at 8:27 AM, Rich Megginson <rmeggins at redhat.com>wrote:
>
>>  On 06/21/2013 08:53 AM, Zane Williamson wrote:
>>
>> Hi Rich,
>>
>>  I do:
>>
>>  drwx------ 2 dsadmin root    4.0K Jun 20 22:44 cookies
>>
>>
>>  Do you see authentication cookies in that directory?
>>
>> Are there any errors in /var/log/dirsrv/admin-serv/error?
>>
>>
>>
>>
>> On Fri, Jun 21, 2013 at 7:15 AM, Rich Megginson <rmeggins at redhat.com>wrote:
>>
>>>  On 06/20/2013 08:11 PM, Zane Williamson wrote:
>>>
>>> Hi 389-users list!
>>>
>>>  I appear to have an issue holding onto authentication when attempting
>>> to save changes to an ldap entry.
>>>
>>>  I am able to authenticate properly, but when I attempt to "Save
>>> Changes"
>>>
>>>  It takes me to:
>>>
>>>  https://mydomain.net/dsgwcmd/domodify
>>>
>>>  Where it says Problem in the header and the page contains.
>>>
>>>  Warning: no authentication (continuing)...
>>>
>>>  It is perplexing me because I was able to verify with the domain admin
>>> on the previous pages, but the "domodify" cgi appears to not have the prior
>>> authentication information provided.
>>>
>>>  Any else see issues like this?
>>>
>>>
>>>  Do you have the /var/run/dirsrv/dsgw/cookies directory?  If so, what
>>> are the ownerships/permissions?
>>>
>>>
>>>  Here is what I am running:
>>>
>>>  389-admin-1.1.9-1.el5
>>> 389-adminutil-1.1.8-4.el5
>>> 389-ds-base-1.2.5-1.el5
>>> 389-dsgw-1.1.4-1.el5
>>>
>>>
>>>  Thanks!
>>> Zane
>>>
>>>
>>>  --
>>> 389 users mailing list389-users at lists.fedoraproject.orghttps://admin.fedoraproject.org/mailman/listinfo/389-users
>>>
>>>
>>>
>>
>>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.fedoraproject.org/pipermail/389-users/attachments/20130621/4dfe97d2/attachment.html>


More information about the 389-users mailing list