[fedora-arm] Strange error with php on F12 sheevaplug

Uroš Kositer uroshsi at gmail.com
Fri Dec 11 07:52:54 UTC 2009


Hi,

echo 1 > /proc/cpu/alignment

outputs 5.2894475160536E-315 and

Dec 11 02:48:32 sheeva kernel: Alignment trap: php (3172)
PC=0x001a21f4 Instr=0xe1c700f0 Address=0x00406bd4 FSR 0x801

in /var/log/messages.

echo 3 > /proc/cpu/alignment

outputs correct result 0.25 and same output in /var/log/messages

Kind regards
Uros

2009/12/11 Kedar Sovani <kedars at marvell.com>:
>> -----Original Message-----
>> From: Uroš Kositer [mailto:uroshsi at gmail.com]
>> Sent: 10 December 2009 20:55
>> To: Kedar Sovani
>> Cc: fedora-arm at redhat.com
>> Subject: Re: [fedora-arm] Strange error with php on F12
>> sheevaplug
>>
>> Hi Kedar,
>>
>> yes, that fixes the problem. Thank you.
>>
>> How can I make this change permanent? By adding this line to
>> /etc/rc.local?
>
> Yes sure. Although making this change will cause your system to be a bit slow.
>
> The right thing to do would be to fix the bug in the php package.
>
> Could you assist in further debugging by:
>
> Option1:
> * echo 3 in /proc/cpu/alignment, this will dump core when the alignment error occurs, thus letting know where exactly did it happen.
>
> Option2:
> * echo 1 in /proc/cpu/aligment, this will put messages in /var/log/messages pointing to where the alignment error might have occurred.
>
>
>>
>> Kind regards
>> Uros
>>
>
> Kedar.
>
>> 2009/12/10 Kedar Sovani <kedars at marvell.com>:
>> >> -----Original Message-----
>> >> From: fedora-arm-bounces at redhat.com [mailto:fedora-arm-
>> >> bounces at redhat.com] On Behalf Of Uroš Kositer
>> >> Sent: 10 December 2009 03:37
>> >> To: fedora-arm at redhat.com
>> >> Subject: [fedora-arm] Strange error with php on F12
>> sheevaplug
>> >>
>> >> Hello to all,
>> >>
>> >> I have recently replaced F11 with F12 on my sheevaplug an I
>> >> came
>> >> across strange php error. Following php script:
>> >>
>> >> <?
>> >> echo 1/4;
>> >> ?>
>> >>
>> >> outputs 5.2894475160536E-315 instead of 0.25.
>> >
>> > I had noticed a few alignment problems while building the new
>> > php. Could you see if this is also because of this?
>> >
>> > Could you please check if it works after enabling fixups.
>> That
>> > is:
>> >
>> > # echo 2 > /proc/cpu/alignment
>> >
>> > And then check it out?
>> >
>> >>
>> >> On F11 everything worked without problems.
>> >>
>> >> Thank you for any suggestions an kind regards
>> >>
>> >> Uros
>> >
>> >
>> > Kedar.
>> >
>> >>
>> >> _______________________________________________
>> >> fedora-arm mailing list
>> >> fedora-arm at redhat.com
>> >> https://www.redhat.com/mailman/listinfo/fedora-arm
>> >
>




More information about the arm mailing list