[fedora-arm] fedora login by uart

Andy Green andy at warmcat.com
Thu Dec 16 08:29:15 UTC 2010

On 12/16/10 05:47, Somebody in the thread at some point said:

> 1.The rootfs is fedora12 which is for arm I download from offical website.
> 2.I used serial port on my PC to connect my board(freescale imx5) and I
> boot my board through NFS Server.
> 3.I am using Fedora13 on my PC.
> 4.I am using "minicom" to communicate.
> And now,I want to use "minicom" to communicate my board,like using some
> commands in shell,but I cannot login the shell on my PC,I cannot input
> the count and password,I can only login by my board.

Hi -

IMX31 kernels have a special tty name, like ttymxc0, I assume it's the 
same on iMX51

This needs some action on the rootfs side...

1)  Ensure you have the ttymxc0 device in the rootfs image

   mknod /dev/ttymxc0 c 207 16

2) Tell the rootfs it's OK to run a login prompt there

   echo "ttymxc0" >> /etc/securetty

I ran agetty directly on /dev/ttymxc0 since I don't use Fedora's boot 
process, so you might also need to look in inittab to start agetty on 
/dev/ttymxc0 at all.

For reference, this is how I ran agetty directly:

   agetty /dev/ttymxc0 115200 vt100-nav


More information about the arm mailing list