[fedora-arm] F14 qemu arm default board

omalleys at msu.edu omalleys at msu.edu
Thu Dec 30 21:37:05 UTC 2010

Quoting Andy Green <andy at warmcat.com>:

> On 12/30/10 18:26, Somebody in the thread at some point said:
> Hi -
>> One instance is when I tried to do the mkrootfs-13 on the guruplug
>> with the default software (apt-get yum rpmbuild etc) the checksums
>> couldn't be verified because the versions of python were different and
>> yum couldn't support the sha256 or whatever checksum algorithm. I had
>> to set up a VM to do that.
> That sounds like the rpm change to xz compression.  That's an  
> unsually tough nut because pre-F12 rpmlib can't even understand  
> post-F12 packages; normally this would work OK.  IIRC they updated  
> F11 rpm back at that time so it could cope with xz via  
> fedora-updates yum repo, enabling a simple upgrade action.  But I am  
> not sure that was ever cooked for arm fedora.
> The quickest solution is uplevel your main rootfs to the f12 tarball  
> and do it from there with an rpm that understands xz already.

The fastest solution was to run the F12 vm since it took about a  
minute to install and get the script running.

>> If you can get performance similar or faster to actual hardware, there
>> will be more interest. If it is pretty easy to set up a VM and add it
> Last time I looked at ARM qemu on quite a beefy Intel box I saw the  
> same kind of 10% of ARM11 performance that Chris mentioned.  Qmeu  
> like that is just not useful for build duty, and real ARMs are  
> getting faster much quicker than x86 iron is pretending to be an ARM  
> so it never will be useful either.

Are you saying you tried the ARM11 kernel with qemu F12 or you just  
tried the versatile kernel with the F12 qemu image off the wiki and it  
gave 10% ARM11 performance?

More information about the arm mailing list