[fedora-arm] Booting Fedora from eMMC

Geert Jansen geertj at gmail.com
Mon Dec 2 16:16:51 UTC 2013


I tried to get F20 booting from the internal eMMC. I did as described
below, but it didn't work. The result is a bricked BBB (I assume I'll be
able to restore it with the 'BBB-EMMC-flasher' image but I haven't tried

 - I installed Fedora to an SD card, and booted from it.
 - From within Fedora, I created a VFAT uboot filesystem and an ext4 root
filesystem on the eMMC.
 - I copied the contents of /boot/uboot and / to the eMMC. I copied with
'tar' and made sure permissions, labels, etc are OK.
 - Changed the filesystem UUIDs in /etc/fstab on the eMMC.

When I boot from the eMMC, the only output on the serial console is
"CCCCCCCC". I can't boot from the SD card anymore either. I gives a bunch
of output, and then hangs on "Starting kernel ...". The latter problem
could be something I messed up myself though, not sure it is related.

Any ideas what I did wrong? Is there a recommended way to get F20 on the

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.fedoraproject.org/pipermail/arm/attachments/20131202/98f75a50/attachment-0001.html>

More information about the arm mailing list