[fedora-arm] Booting Fedora from eMMC

Robert Nelson robertcnelson at gmail.com
Mon Dec 2 23:26:15 UTC 2013

On Mon, Dec 2, 2013 at 10:16 AM, Geert Jansen <geertj at gmail.com> wrote:
> Hi,
> I tried to get F20 booting from the internal eMMC. I did as described below,
> but it didn't work. The result is a bricked BBB (I assume I'll be able to
> restore it with the 'BBB-EMMC-flasher' image but I haven't tried yet):
>  - I installed Fedora to an SD card, and booted from it.
>  - From within Fedora, I created a VFAT uboot filesystem and an ext4 root
> filesystem on the eMMC.
>  - I copied the contents of /boot/uboot and / to the eMMC. I copied with
> 'tar' and made sure permissions, labels, etc are OK.
>  - Changed the filesystem UUIDs in /etc/fstab on the eMMC.
> When I boot from the eMMC, the only output on the serial console is

This means you either deleted the MLO/u-boot.img on the boot media, or
copied the boot files and renamed..

The omap boot rom, can be pretty picky, I always rm MLO, then copy the
new version, then delete u-boot.img and then copy that..

> I can't boot from the SD card anymore either. I gives a bunch of
> output, and then hangs on "Starting kernel ...". The latter problem could be
> something I messed up myself though, not sure it is related.

Could be serial issues, or the wrong u-boot address's..

> Any ideas what I did wrong? Is there a recommended way to get F20 on the
> eMMC?


Robert Nelson

More information about the arm mailing list