[fedora-arm] Booting Fedora from eMMC

Peter Robinson pbrobinson at gmail.com
Sun Dec 8 23:21:10 UTC 2013

> I tried to get F20 booting from the internal eMMC. I did as described below,
> but it didn't work. The result is a bricked BBB (I assume I'll be able to
> restore it with the 'BBB-EMMC-flasher' image but I haven't tried yet):
>  - I installed Fedora to an SD card, and booted from it.
>  - From within Fedora, I created a VFAT uboot filesystem and an ext4 root
> filesystem on the eMMC.
>  - I copied the contents of /boot/uboot and / to the eMMC. I copied with
> 'tar' and made sure permissions, labels, etc are OK.
>  - Changed the filesystem UUIDs in /etc/fstab on the eMMC.
> When I boot from the eMMC, the only output on the serial console is
> "CCCCCCCC". I can't boot from the SD card anymore either. I gives a bunch of
> output, and then hangs on "Starting kernel ...". The latter problem could be
> something I messed up myself though, not sure it is related.
> Any ideas what I did wrong? Is there a recommended way to get F20 on the
> eMMC?

The latest release of our uboot should fix this problem. I would also
have a tendency to copy the image file onto the SD card and then
dd/xzcat it directly onto the eMMC.


More information about the arm mailing list