[fedora-arm] cubietruck boots from sdcard, but f21 doesn't find mmcblk

Cole Robinson crobinso at redhat.com
Wed Feb 25 14:19:13 UTC 2015

Hey all,

First time trying to setup my cubietruck/cubieboard3. I used
fedora-arm-installer[1] to fill in an 8GB sd card on my host machine, using

Pop it into my cubietruck, connect via serial console, start it up. Machine
passes uboot fine and boots the initrd, but eventually fails waiting for the
root mount point to show up, and falls back to dracut.

Comparing my boot output to kashyap's[2], my machine has all the same messages
referencing 'mmc1', but there's nothing about mmc0. mmcblk0 never shows up, so
the boot fails after a timeout.

So I populated a SATA drive in the same way as above, hooked that to the
cubietruck, and it boots successfully. But I still can't access the sdcard
from fedora. The only thing under /sys/block is sda. Tried removing and
re-inserting the sunxi_mmc module, doesn't seem to help. Tried another sd
card, didn't make a difference.

I updated the kernel on the sdcard (by updating /boot on the sata drive,
sticking the sdcard in a USB adapter, rsyncing the contents), booted into the
latest lpae kernel, but still the sdcard isn't detected.

Anyone have any ideas? Googling didn't turn up anything.

If not, is it possible to make the cubietruck boot directly off the sata
drive? Doesn't seem to work for me, but if I can make that work I don't need
to worry about the sdcard.


[1]: https://fedoraproject.org/wiki/Architectures/ARM/F21/Installation#Scripted

More information about the arm mailing list