Known mock/yum problem?

Paul Howarth paul at
Mon Jun 25 16:06:11 UTC 2007

seth vidal wrote:
> On Mon, 2007-06-25 at 16:18 +0100, Paul Howarth wrote:
>> Came across an oddity today and I'm not sure if it's mock or yum that's 
>> the problem.
>> I'm running with these updates from updates-testing (on an FC7 host):
>> mock-0.7.2-1.fc7
>> yum-3.2.1-1.fc7
>> My rawhide mock config points to a single baseurl for the fedora repo, 
>> and goes through a local squid proxy. I'm also using autocache.
>>  From time to time packages cannot be retrieved over the network, 
>> perhaps due to the mirror being in mid-sync, or maybe transient network 
>> issues.
> Try this as a good test: Make a package with a BuildRequires:
> something-that-doesn't-exist
> If the build doesn't bail, then we have a problem, if it does bail, then
> we're fine.
> Can you test that and let me know?

OK, tried this:

* Got a simple perl module package and added a buildreq of 
perl(No::Such::Module) to it.
* Tried building it: mock failed as I'd have expected ("No Package Found 
for perl(No::Such::Module)")

To more accurately mimic the issue I was seeing, I then:

* Created a dummy perl-No-Such-Module package that provided 
* Added that package to a local repo that's in my mock config
* After running createrepo to update the metadata, I then deleted the 
actual RPM from the repo
* Tried building the original perl module package

This reproduced what I was seeing; the dependency seemingly being 
available from the metadata was sufficient for mock to proceed to the 
build phase.

The consequences aren't as bad as I'd thought though, as yum doesn't 
seem to have installed *any* of the buildreqs in the setup phase, which 
would cause most package builds to fail.


More information about the buildsys mailing list