[FZH] [!!!求助】新装fedora16 内置扬声器有声,耳机无声

杜宏羽 dongfengweixiao at gmail.com
Tue Feb 14 04:14:07 UTC 2012


安装所有的alsa包后重启。
在 2011-11-21 下午10:24,"liaoyifei" <lyfbuaa在163.com>写道:

>
>  插上耳机还是内置扬声器发声
>
> alsamixer   里MM也都取消试过,
>
> processor    : 0
> vendor_id    : GenuineIntel
> cpu family    : 6
> model        : 42
> model name    : Intel(R) Core(TM) i5-2415M CPU @ 2.30GHz
> stepping    : 7
> cpu MHz        : 800.000
> cache size    : 3072 KB
> physical id    : 0
> siblings    : 4
> core id        : 0
> cpu cores    : 2
> apicid        : 0
> initial apicid    : 0
> fpu        : yes
> fpu_exception    : yes
> cpuid level    : 13
> wp        : yes
>
>
> [@mylinux ~]$ head -1 /proc/asound/card0/codec#*
> ==> /proc/asound/card0/codec#0 <==
> Codec: Cirrus Logic CS4206
>
> ==> /proc/asound/card0/codec#3 <==
> Codec: Intel CougarPoint HDMI
>
>
>
> [@mylinux ~]$ tail -100 /proc/asound/oss/sndstat
> Sound Driver:3.8.1a-980706 (ALSA v1.0.24 emulation code)
> Kernel: Linux mylinux 3.1.1-2.fc16.x86_64 #1 SMP Mon Nov 14 15:46:10 UTC
> 2011 x86_64
> Config options: 0
>
> Installed drivers:
> Type 10: ALSA emulation
>
> Card config:
> HDA Intel PCH at 0x90900000 irq 46
>
> Audio devices: NOT ENABLED IN CONFIG
>
> Synth devices: NOT ENABLED IN CONFIG
>
> Midi devices: NOT ENABLED IN CONFIG
>
> Timers:
> 31: system timer
>
> Mixers: NOT ENABLED IN CONFIG
>
>
> 如果执行:modprobe snd_pcm_oss
>
> 上面的Audio devices  Mixers  会enable   但是问题依旧
>
>
>
> [@mylinux ~]$ cat /proc/asound/modules
>  0 snd_hda_intel
>
>
> [@mylinux ~]$ lspci |grep Audio
> 00:1b.0 Audio device: Intel Corporation 6 Series/C200 Series Chipset
> Family High Definition Audio Controller (rev 05)
>
> [@mylinux ~]$ lsmod |grep snd
> snd_hda_codec_hdmi     23548  1
> snd_hda_codec_cirrus    15200  1
> snd_hda_intel          24072  4
> snd_hda_codec          85181  3
> snd_hda_codec_hdmi,snd_hda_codec_cirrus,snd_hda_intel
> snd_hwdep               6264  1 snd_hda_codec
> snd_seq                52186  0
> snd_seq_device          5941  1 snd_seq
> snd_pcm                78498  4
> snd_hda_codec_hdmi,snd_hda_intel,snd_hda_codec
> snd_timer              19372  2 snd_seq,snd_pcm
> snd                    63124  16
> snd_hda_codec_hdmi,snd_hda_codec_cirrus,snd_hda_intel,snd_hda_codec,snd_hwdep,snd_seq,snd_seq_device,snd_pcm,snd_timer
> soundcore               6267  1 snd
> snd_page_alloc          7311  2 snd_hda_intel,snd_pcm
>
>
> 加了下面配置(#号都轮流打开试过)问题依旧:
> /etc/modprobe.d/alsa-base.conf
>
> #alias snd-card-0 snd-hda-intel
> #alias sound-slot-0 snd-hda-intel
> #enable_msi=1   position_fix=1
> #options snd-hda-intel model=imac27
> #options snd-hda-intel model=auto
> #options snd-hda-intel enable_msi=1
> #options snd-hda-intel enable=yes
>
>
>
>
> --
> Fedora中文郵件列表:https://admin.fedoraproject.org/mailman/listinfo/chinese
>


More information about the Chinese mailing list