Cloud projects inside of RedHat

Chris Lalancette clalance at
Thu Dec 16 13:07:28 UTC 2010

On 12/16/10 - 07:59:37AM, Kashyap Chamarthy wrote:
> >>If it is indeed something to do with iptables (as I suspect), then the
> >>following *might* help out:
> >>
> >>$ sudo virsh net-destroy default
> >>$ sudo virsh net-start default
> Ok, I spoke a little too early. I think this worked.
> >
> >hm, I tried this, and re-ran oz-install, as of now, it is on it's way to getting timed out..
> And it actually didn't time out :) It did seem to install after a
> few mins (attached is my  sanitized oz-output).
> Now, I tried a virt-viewer <new-f14-JOES> . I see a blank screen. So
> tried to access a 'virtual terminal', I didn't get any. Am I
> supposed to get any?
> so I tried to run `arp` :
> ================
> [kashyap at foobar ~]$ arp -an
> ? (10.x.y.z) at 00:16:36:07:bc:7d [ether] on eth0
> ? ( at <incomplete> on virbr0
> kashyap at foobar ~]
> ================
> so what can I do next ? Shutdown the guest and mount it's file
> system with `guestfish` tool and make some changes?

Yep, that looks like it worked.  I'm pretty sure that the
"net-destroy ; net-start" virsh commands are what fixed it; you were missing
the MASQUERADE rules in the iptables NAT table to allow guests to get out
via the virbr0 interface.

Now that you've gotten by that, you should have an installed OS.  At the end
of the install, oz actually shuts down the machine.  At this point you have a
raw VM diskimage, so you should be able to do whatever it is you usually do
with a VM diskimage:

1)  Use guestfish to modify it
2)  Use virsh to start it in and login


I will note that I have had some problems in particular with an F-14 guest
and a blank screen.  I'm not sure exactly whether the problem I'm seeing is on
the host or guest, and I haven't yet had time to track it down.  If you are
seeing an entry in the ARP cache, you may be able to ssh into the machine.

Chris Lalancette

More information about the cloud mailing list